Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-06-2004, 09:51 PM
Registered User
 
Join Date: Feb 2003
Location: New York
Posts: 161
Question Highway cruise fluctuations 85 300TDT

I've been noticing a uneveness when cruising at 55-60mph. It seems like I have a faulty filter. I changed both fuel filters 3k ago. Does anyone have any experience with the tank filter on a 85300td. Could that be clogged? Also could it be my fuel pump or maybe the injector pump? Is there any test? Just don't want to suddenly die on the road. Approaching 400k miles probably by summer so I have some concerns. Any input appreciated. Thanks
__________________
85 300TDT 456,000 orig. miles
Reply With Quote
  #2  
Old 01-06-2004, 09:57 PM
Registered Diesel Burner
 
Join Date: Aug 2001
Location: Northern Virginia
Posts: 2,911
Also take the fuel primer pump into consideration if you have an original. Check to see that the pump handle is screwed down tight as a minimum. Look for diesel weepage in that area.

Look for air bubbles entering the plastic fuel pre-filter - that indicates a leaking supply line between it and the tank, possibly the one right there at the pre-filter. Also look for foreign matter like specs of algae/fungus. Your spin-on filter is probably not clogged with tank scum unless the pre-filter is getting clogged too.

I did die on the road once so far and it was the fuel primer pump leaking air into the system - the handle had come loose running down the road.

Ken300D
__________________
--------------------------
1982 300D at 351K miles
1984 300SD at 217K miles
1987 300D at 370K miles
Reply With Quote
  #3  
Old 01-06-2004, 10:37 PM
Registered User
 
Join Date: Feb 2003
Location: New York
Posts: 161
I'll take a look at the pre filter. As far as the primer pump, that was changed along with the folter 3k ago. Thanks, I'll also look for algae.
__________________
85 300TDT 456,000 orig. miles
Reply With Quote
  #4  
Old 01-07-2004, 12:54 AM
Palangi's Avatar
L' Résistance
 
Join Date: Dec 2000
Location: Republique de Banana
Posts: 3,496
When mine had cruise fluctuations, I found that the shaft on top of the valve cover where the linkage from the cruise actuator pivots was loose and wobling in it's bracket. Fixed with JB weld.
__________________
Palangi

2004 C240 Wagon 203.261 Baby Benz
2008 ML320 CDI Highway Cruiser
2006 Toyota Prius, Saving the Planet @ 48 mpg
2000 F-150, Destroying the Planet @ 20 mpg



TRUMP .......... WHITEHOUSE
HILLARY .........JAILHOUSE
BERNIE .......... NUTHOUSE
0BAMA .......... OUTHOUSE
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page