Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-07-2004, 01:11 PM
shawnster
Guest
 
Posts: n/a
Massive THUD from passenger's rear wheel

I have a '81 300TD wagon.

In summer I replaced the nitrogen cells and rear sway bar links with an immediate improvement in the ride. In August, when I checked, the SLS was working great.

Now, over the last few months I'm experiencing a really, really massive THUD with even relatively small bumps. It seems to be isolated to the passenger's rear corner of the car.

I've checked fitment of the doors, and checked to make sure that the jack/ tool kit are secured.

Anybody else out there with this experience?
Reply With Quote
  #2  
Old 01-07-2004, 02:17 PM
Registered User
 
Join Date: Aug 2001
Location: Evansville, Indiana
Posts: 8,150
Check the lower bushing on the strut and the connections to the swaybar, also the swaybar to frame bushings. Check for a loose spare tire, too, even though it's on the other side.

Peter
__________________
1972 220D ?? miles
1988 300E 200,012
1987 300D Turbo killed 9/25/07, 275,000 miles
1985 Volvo 740 GLE Turobodiesel 218,000
1972 280 SE 4.5 165, 000 - It runs!
Reply With Quote
  #3  
Old 12-09-2004, 09:38 PM
Registered User
 
Join Date: Sep 2003
Posts: 187
what about the rear subframe bushing? Check that as well.
__________________
'73 VW camper
'80 300td wagon
Reply With Quote
  #4  
Old 12-09-2004, 10:32 PM
phidauex's Avatar
BioDiesel Hopeful
 
Join Date: Oct 2004
Location: St. Louis, MO
Posts: 806
I get an occasional 'thock' sound from my passenger side rear strut, due to a little bit of air being inside of it. The system is supposedly self-bleeding, and when I disconnected the linkage on the self-leveling valve and moved it up and down a bunch, raising and lowering the rear end, the sound almost completely went away, though I hear it a little bit on big bumps.

I'd check your self leveling fluid level, and look for leaks on the strut. In addition to the other fine suggestions.

peace,
sam
__________________
"That f***in' biodiesel is makin' me hungry."

1982 300TD Astral Silver w/ 250k (BIO BNZ)
2001 Aprilia SR50 Corsa Red w/ 5.5k (>100 MPG)

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:23 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page