Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-23-2004, 03:08 PM
Registered User
 
Join Date: Feb 2004
Location: Berkeley, California
Posts: 214
Thanks, and an into - 1980 300D - Greasecar

Hey there, thanks a ton to all of you for creating this excellent pool of knowlege. The archives here are amazing. It's helped me a ton. I wish I'd gotten here sooner, as I just replaced the tranny in my 300D and after reading the archives, I suspect I didn't need to. Ooops. It was flaring badly on all shifts, and kept doing it with the new tranny.

Here's the deal: The car has an aftermarket TC, a RayJay from back in the day. Adding this TC apparently required the removal of the EGR system. I was just about to replace my switch over valve, 'cause the vacuum to the modulator wasn't going down with increased throttle, thus the soft shifts and flaring. Turns out that the vac line going to the EGR valve, through the 17C temp switch had simply been plugged. When I disconnected the vac line to that temp switch, the tranny shifts like a champ. Shift point for the 3/4 is a little high for my taste, but still a whole new world of tasty tranny action.

So I still have to do some work on the ACC action, I'm losing some coolant from the servo, and my heat doesn't work at present, but I am not afraid. I figure if I can swap trannys in my driveway, there's nothing on this car I can't do.

I also installed a second fuel system on this car, with a heated 24 gallon tank in the trunk, and a heated 10mic filter in the front. *This* 300D burns straight vegetable oil. Woo woo!

Oh, so has anyone heard of problems with aftermarket TC's on normally aspirated cars? Something about missing oil-jets under the pistons... I heard a tale of an old diesel (220D?) burning up a piston from an afterthought TC. How fast does your 300D go? Mine'll get up to 80 real easily, but shudders a bit above that. Prolly need some suspension work... alignment and wheel balance, at least.

Oh, one more question for now, the lights for my instruments and ACC console are out. The came on for a little while, a couple weeks ago, but now they're out again. Is there a common cause/simple fix? Thanks a ton, you all, and I'm looking way forward to becomming a member of the community.

Cheers,
Ash
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page