Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-24-2004, 11:05 PM
JHZR2's Avatar
Registered User
 
Join Date: Jan 2002
Location: New Jersey
Posts: 4,908
CEL from 606 EGR - How can I clean it out?

Hi,

My father's 96 E300d has had some check engine light issues lately. First it was the throttle position sensor that set the light when the cruise control was used. Replaced it and all was well. Then a glow plug burned out. did that job (we cranked it with the gps out and the intake off, and got a light due to injector circuits being open as well), got the codes cleared, and then all was well. Drove it from cold to full temp, all speeds, etc. Seemed fine.

I just got word that the light came back on, this time because of improper airflow through the EGR. This tells me that it is either stuck open or closed. Is this typical?

One thing I do know is that there was a lot of goop in the intake, both in the manifold holes and in the holes in the head. Id perhaps say that almost 1/2 of the hole areas on the manifold side were clogged from this stuff.

Using a popsicle stick, we cleaned it from the holes in the head, we then used come carb cleaner and sticks to get the junk from the manifold, as far as we could reach in. We were very thurough, although I guess dipping it would have been better.

Anyway, my guess is that perhaps the remains of that gunk that we didnt manage to get out has freed itself, been ingested, burned and spit out, only to collect on the EGR valve, causing it to not open and close properly. I cant imagine what else it could be, after all, we drove the car quite a bit with no light, then all of a sudden, on it comes. Its pretty bad too, if the code is erased, apparently it comes on as soon as the car is restarted (I thought the egr only worked above idle, below WOT, and when the engine was up to temp?

Any suggestions? well have to have a close look for an electronic connection that maybe we caused to loosen a bit, and then rattled off with driving?

Any help would be great. Hopefully one of these days the CEL will stay off.

Thanks,

JMH

__________________
Current Diesels:
1981 240D (73K)
1982 300CD (169k)
1991 350SD (113k)
1991 350SD (206k)
1991 300D (228k)
1993 300SD (291k)
1993 300D 2.5T (338k)
1996 Dodge Ram CTD (442k)
1996 Dodge Ram CTD (265k)

Past Diesels:
1983 300D (228K)
1985 300D (233K)
Reply With Quote
  #2  
Old 05-25-2004, 11:59 AM
Rick Miley's Avatar
Spark Free
 
Join Date: Jun 1999
Location: Land O Lakes, FL
Posts: 3,086
Sounds like you need to take the manifold back off, take the EGR valve off and clean it out. While it is off, test it with your MityVac to be sure it opens and closes properly.

__________________
Rick Miley
2014 Tesla Model S
2018 Tesla Model 3
2017 Nissan LEAF
Former MB: 99 E300, 86 190E 2.3, 87 300E, 80 240D, 82 204D Euro
Chain Elongation References
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page