Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion > Diesel Performance Tuning

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-08-2011, 05:57 PM
Registered User
 
Join Date: Jan 2011
Location: South East Virginia
Posts: 31
84 300D trans problem

This is my first post... subject car has 174K miles on it and was given to me yesterday and there seems to be something wrong with the trans? she started up/idled fine... popped hood, there is excess oil leaking from valve cover? and there is oil around all five ejectors there's an 8" oil leak in my drive way, looks like it's coming from rear engine/trans area (it's engine oil). Road test - 1st, 2nd gear shift ok after this engine rpm's go up, no 3rd gear 20-25 mph and thats it... check trans fluid level "good"... Is this a trans problem or vacuum or blown engine... What should I do before taking it to the shop.

Thanks for the replies in advance and I look forward to owning and operating a 300D W123 on a daily basis for many years, one way or the other.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page