Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz Performance Paddock

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-03-2017, 03:27 PM
Registered User
 
Join Date: Oct 2013
Posts: 16
Question '97 S420 Cruise Control Failing?

Ok, so -
I don't know whats up - the cruise control on my car works about 50% of the time now. The other day it was working, I could feel it accelerating to maintain speed up a small hill, but at the top of the hill I could feel the engine "relax" and stop working and the speed start falling. This was the only time that I noticed the CC stop working - but half the time it works fine and the other half it just doesn't.

I've check a few thing (vacuum lines, fuses etc.), but I just don't know this system very well - and guidance on where to start troubleshooting would be cool.

Adam
Reply With Quote
  #2  
Old 05-03-2017, 03:39 PM
Registered User
 
Join Date: Oct 2013
Posts: 16
Question Some more symptoms

I've also noticed that it seems (and I might be imagining it) that the brake pedal is a little stiffer when the CC isn't working... but "normal" when it is working.

thoughts?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page