Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz Performance Paddock

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-29-2017, 09:25 PM
Registered User
 
Join Date: Oct 2013
Posts: 16
1997 S420 - rough/smelly start when outside temp is HOT

Ok,
I have a 1997 S420 - I've noticed an issue with the idle at startup - particularly when it is hot outside (over 90). The car starts really rough (feels like dropping a cylinder) then as it "warms up" - it smoothes out, it's always had a bit of a miss in the idle (like, REALLY minor - I'm the only one that can notice it) and when it starts rough it smells really gassy (which could just be attributed to too much unburnt fuel passing out the tailpipe - since it clearly is missing)

I've checked as well as I can the vacuum lines
and replaced the temp sending unit (changed it unrelated to this issue - but I've noticed this problem before changing the temp sending unit.)
I have a new purge valve on order (since I would wager the one in the car is original)

Anything else I should look into?

Adam
Reply With Quote
  #2  
Old 08-29-2017, 09:34 PM
Registered User
 
Join Date: Oct 2004
Posts: 3,227
Leaking fuel pressure regulator? Pull the hose off and check for gas.
__________________
90 300TE 4-M

Turbo 103, T3/T04E 50 trim
T04B cover .60 AR
Stage 3 turbine .63 AR
A2W I/C, 40 LB/HR
MS2E, 60-2 Direct Coil Control
3" Exh, AEM W/B O2
Underdrive Alt. and P/S Pulleys,
Vented Rear Discs, .034 Booster.
3.07 diffs, 1st Gear Start

90 300CE 104.980
Milled & ported head, 10.3:1 compression
197 intake cam w/20 advancer
4 ignition advance
PCS TCM2000 running 722.6 trans, 600W PWM fan, water injection
Sportline sway bars
V8 rear subframe, Quaife ATB 3.06 diff
Reply With Quote
  #3  
Old 09-20-2017, 02:58 PM
Registered User
 
Join Date: Oct 2013
Posts: 16
Not Fuel regulator

Wasn't the regulator, but I replaced it anyway. I did find a couple small leaks in some vacuum lines (replaced them) Idles REALLY smooth now... BUT

I get a p0410 code...

so -

Does anyone know how to pull the valve without taking the fron of the engine apart? the screws/bolts are on the underside of the valve and I don't know how to reach them.

Does anyone know the routing of the secondary air system? Does it dump directly into the exhaust pipe, or does it go through the head - if through the head I think I'm lost... I don't want to pull the heads...

HELP!

adam
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:07 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page