Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz Performance Paddock

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-26-2018, 12:38 PM
Registered User
 
Join Date: Aug 2007
Location: Southern California
Posts: 373
M104 Cam Advance RPM Window

Does anyone know what the RPM window for activating the cam advance solenoid is on a M104.980 motor?

I pulled a M104.980 from a 91 300CE, dropped it in a 190E body, and am running old CIS v3 with the system so I do not have cam advance. I plan to wire in an RPM activated switch to engage the solenoid, but I would like to know what RPM range I should use?

I've come across posts saying 2000-5000 is when the advance kicks in, but nothing from an official PDF or anything. Is this the right range? Is there a better range to use?

The car doesn't feel much different from my M103 2.6, so I'm hoping adding the cam advance will pick up some mid range power.
Reply With Quote
  #2  
Old 03-26-2018, 07:29 PM
Registered User
 
Join Date: Oct 2004
Posts: 3,225
I don't have official documents in front of me but IIRC its off at idle, on at 1200, off again at 5200.
__________________
90 300TE 4-M

Turbo 103, T3/T04E 50 trim
T04B cover .60 AR
Stage 3 turbine .63 AR
A2W I/C, 40 LB/HR
MS2E, 60-2 Direct Coil Control
3" Exh, AEM W/B O2
Underdrive Alt. and P/S Pulleys,
Vented Rear Discs, .034 Booster.
3.07 diffs, 1st Gear Start

90 300CE 104.980
Milled & ported head, 10.3:1 compression
197 intake cam w/20 advancer
4 ignition advance
PCS TCM2000 running 722.6 trans, 600W PWM fan, water injection
Sportline sway bars
V8 rear subframe, Quaife ATB 3.06 diff
Reply With Quote
  #3  
Old 03-26-2018, 08:04 PM
tyl604's Avatar
Registered User
 
Join Date: Feb 2008
Location: Atlanta, GA
Posts: 3,211
I wonder if anyone recognized the loopback in your location.
Reply With Quote
  #4  
Old 03-26-2018, 09:16 PM
Registered User
 
Join Date: Jan 2012
Posts: 7,146
Off at 5,200 sounds kind of high. My 97 SL320 ( With ME 2.0 / 2.1 ) has a " power surge " at maybe 3,600 and 4,300 RPM. One of these is going to be the dual path intake switching. Someday I'll add a few lights to monitor.

The timing is retarded at idle to promote a smoothness, that is why it is off / on / off. Since you are running CIS, maybe leave it advanced at idle to X RPM for a bit more low end zip.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page