Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz Performance Paddock

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-28-2018, 05:58 AM
rwd4evr's Avatar
Master hull craftsman
 
Join Date: Apr 2012
Location: delaware
Posts: 591
4.5 m117.982 low oil pressure?

My 450slc drift car has a basically stock lowish mile us spec m117. I never trusted the oil pressure gauge before the new motor went in and I still don't. So I installed an aftermarket gauge. Probably should have spent a little more on it but it seems to work. Once the car is good and warm and basically heat soaked at about 190-205 after constant thrashing the aftermarket is reading a bit worrisome on the low side. Like below 10 at idle and I've seen as low as 25 psi at 5000 plus rpm( where it is a lot). One issue is that the gauge has a tiny hole on the inlet that I assume is to reduce flutter but it slows the movement a lot. The other issue that could be leading to this low reading I think may be the spot I'm pulling pressure from. I retained the stock gauge since it's an odd fitting and drilled and tapped an Allen head button plug on the back of the head right near the factory fitting. I'm thinking that it is the oil galley that feeds the cam and cam squirter tubes. Is it possible that the top end is only fed a certain amount of oil with a restriction and once the oil is thin and it's being squirted out of all the clearances it's just a false low reading? The factory gauge jumps to full just off idle but does read a little lower when hot. I want to hook up into the factory port to see if it cures the issue but it's not very accessable in the car. First thing I'm doing is drilling the hole out a bit to get a faster reading. My other thought is that the oil cooler I installed (factory 350sl) has a regulator that's bleeding off to much. I disconnected it and I'll be doing some testing this weekend I hope. I have a drift event Jan 20 and I'd like to not be worried about it. My positive thoughts are that since it survived 4 events already it's fine but...... Anyone have any insight on the m117 top end oiling or if I could have a pump/relief pickup issue? The motor is 111,000 mile. Fresh guides chain cam gears. Very minimal blow by. Revs clean to 6500. I didn't have the pan off the motor so i don't know if it's full of garbage and unfortunately the stupid r/c107 pan is one piece and the motor will have to come out to look.
__________________
WARNING!!! VINTAGE MERCEDES MAY MULTIPLY UNCONTROLABLY!!! I have tons of Sl/Slc parts w108 w111 w126 and more. E-mail me with needs
BirchsgarageMB@gmail.com
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:13 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page