PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Mercedes-Benz Performance Paddock (http://www.peachparts.com/shopforum/mercedes-benz-performance-paddock/)
-   -   Coolant problem with W124 300E (http://www.peachparts.com/shopforum/mercedes-benz-performance-paddock/45164-coolant-problem-w124-300e.html)

speedracer888 08-29-2002 12:47 AM

Coolant problem with W124 300E
 
My engine is spraying coolant everywhere <=\

The house came off (under pressure??) and it sprayed it all over my engine. After having my car towed home, that's when I found out.

Anyone have this problem before? I've always had coolant problems with my car... :(

jsmith 08-29-2002 07:23 AM

well, if it's a hose that came off you just secure it properly. if it's that little elbow fitting up top, you gotta replace it...

J.HIDALGO 08-29-2002 10:20 AM

Which hose and where?
 
:confused:

speedracer888 08-29-2002 04:22 PM

the coolant hose leading to the radiator

it's loose, I put it back on but it's not a tight seal

Anyone know how to tighten it?

J.HIDALGO 08-29-2002 06:29 PM

If it is the top radiator hose...
 
check the neck of your radiator. It may be cracked. Common failure in these cars.:rolleyes:

speedracer888 08-30-2002 12:02 AM

ok, thanks! it's on tightly but still dripping down...

anthonyb 08-30-2002 12:15 AM

This may sound like a dumb question, but did you check to see if the hose clips were still installed? Normally, when a hose leaks, all you have to do is just tighten the clip a little more; if your hose completely let go, I could see how one might have fallen off onto the roadway, and there's no way you'll be able to stop the leaking.

-a

anthonyb 08-30-2002 12:55 AM

This may sound like a dumb question, but did you check to see if the hose clips were still installed? Normally, when a hose leaks, all you have to do is just tighten the clip a little more; if your hose completely let go, I could see how one might have fallen off onto the roadway, and there's no way you'll be able to stop the leaking.

-a

speedracer888 08-30-2002 04:21 AM

the hose clips are still there. I tightened it. It all looks ok now...

with all of these problems, turbo/NOS ing it will look bad...
:(

Chris17H 09-02-2002 01:42 PM

UH OH, i had this same problem with my car, I would drive and all the sudden the upper radiator hose would pop off, coolant everywhere. here is what I would have checked out

1. If u havn't done so alreay, replace the thermostat housing with the upgraded metal one for better fitting.
2. Check upper radiator neck for cracks or completely broken,
3. Have the water pump checked out...Mine started leaking from taking too long to repair the radiator.
4. Be sure to have all your radiator hoses replaced when getting the radiator done
5. One last thing, refill it with MB Coolant


I never really knew what went first, the radiator or the water pump, but i'd just get them both checked out...Soryy to say this cost me a total of around 1100, and ALOT of frustration:mad:
Good Luck:D


All times are GMT -4. The time now is 01:28 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website