Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #16  
Old 08-04-2007, 02:43 AM
lynns's Avatar
Registered User
 
Join Date: Mar 2004
Location: So. California
Posts: 295
Quote:
Originally Posted by MrMajstyk View Post
I bought my 1996 SL500 a couple of weeks ago...and been doing a lot of reading here and on other boards...seems like almost EVERYONE has soft top raising and lowering issues. I haven't had the hard top off my car yet...no winch, and no one around to help...but I'm starting to think maybe I'll just leave it on. I mean, does anyone NOT have a problem with their top???? This seems to be a VERY common problem...
Please read FRONT cylinders that have been replaced and
R129 Hydraulic System-Cylinder post and
R129 'Soft Top Controller' post
__________________
Mit freundlichen Grüßen, Lynn

2000 SL500 Silver
2000 SL500 SOLD
1989 560SL SOLD
1988 560SL SOLD

Last edited by lynns; 08-07-2007 at 12:43 AM.
Reply With Quote
  #17  
Old 08-06-2007, 11:14 PM
elau's Avatar
Registered User
 
Join Date: Nov 1999
Location: MD.
Posts: 1,725
Haha.......knock on wood. I have more battery related problems than the top mechanism. I only drive it top down, so the mechanism gets the work every time. I have not used the hard top since 1998.

Enjoy it. Its a great car!!!
__________________
95 R129
04 Infiniti G35.5 BS
10 X204
Reply With Quote
  #18  
Old 08-07-2007, 09:21 AM
Registered User
 
Join Date: Aug 2007
Posts: 17
Lots of top up and down on my 95. I did have the leakly pistons in the header, actually on the drivers side but I replaced both (had them replaced, It wasn't too expensive but I don't remember how much).
The biggest problem was with the control unit. My top light button would not go out and neither the top nor the Windows would go up or down, luckly they were up. I tried all of the resetting tips to no avail. I had to have a new control unit put in, I think about $600 for the unit. This was a case where for a while, everytime I started the car it would take longer and longer for the red light to go out, then it would just come on intermittently at times while driving until finally it came on and stayed on.
I have the old unit, do you think there's any market for it? Can it be repaired? What do you think it might be worth?

I still have the origonal top but it does need replacing. The top itself is in fairly good shape but the windows are pretty messed up. The two sides windows have cracks from the folding / unfolding and the main window is pretty scratched up. I know I can replace just the rear section of the top but I'll probably do the whole thing instead.
Reply With Quote
  #19  
Old 08-07-2007, 10:37 AM
lynns's Avatar
Registered User
 
Join Date: Mar 2004
Location: So. California
Posts: 295
Quote:
Originally Posted by sljoe View Post
The biggest problem was with the control unit. My top light button would not go out and neither the top nor the Windows would go up or down, luckly they were up. I tried all of the resetting tips to no avail. I had to have a new control unit put in, I think about $600 for the unit. This was a case where for a while, everytime I started the car it would take longer and longer for the red light to go out, then it would just come on intermittently at times while driving until finally it came on and stayed on.
I have the old unit, do you think there's any market for it? Can it be repaired? What do you think it might be worth?.
You can get a rebuilt R129 Convertible Top Controller for $375.00 with a two year warranty at http://www.bba-reman.com/catalogue/DetailedProduct.aspx?DetailedProduct=896

"We send you out a working unit and you send your old unit back after you fit this one. If for any reason we do not receive your old unit back, there would be an additional charge of $150"
__________________
Mit freundlichen Grüßen, Lynn

2000 SL500 Silver
2000 SL500 SOLD
1989 560SL SOLD
1988 560SL SOLD
Reply With Quote
  #20  
Old 08-08-2007, 02:46 PM
Registered User
 
Join Date: Aug 2007
Posts: 17
Lynn,
If I knew then what I know now....
Reply With Quote
  #21  
Old 08-15-2007, 11:42 PM
Registered User
 
Join Date: Jul 2007
Location: Cumming GA
Posts: 3
Quote:
Originally Posted by MB-Dude View Post

Your fix is very simple. There are two hydraulic cylinders (MB p/n: 129.800.16.72) in the top of the frame, above the windshield. These are accessed quite easily ...
Thanks for your help! It leaked on me again today after a period being dormant...I will need to do this fairly soon. BTW whats the hydraulic reservoir at the front of the motor on the left side? power steering? if so do know the correct fluid part nos? thxs
Reply With Quote
  #22  
Old 08-16-2007, 12:50 AM
lynns's Avatar
Registered User
 
Join Date: Mar 2004
Location: So. California
Posts: 295
Quote:
Originally Posted by DucatiErv View Post
BTW whats the hydraulic reservoir at the front of the motor on the left side? power steering? if so do know the correct fluid part nos? thxs
You are probably referring to the Adaptive Damping Suspension System (ADS) hydraulic reservoir on a 94 SL600. You can use the same hydraulic fluid that is used for your convertible top hydraulic system. p/n 000989910310 The reservoir for the top is located in the trunk under the spare tire. If you are losing fluid from your front cylinders you will probably want to check the level or do a total fluid renew after you do an R&R of the cylinders.

Be aware that both hydraulic systems require a different p/n for the fluids. Please feel free to read R129 Convertible Top Hydraulic cylinder/system post if you want to fully understand the convertible top and its various components, etc.

The p/n for the top fluid can be found at convert top hydraulic fluid p/n . I'm sorry but I don't have ADS and don't know the p/n for the fluid.
__________________
Mit freundlichen Grüßen, Lynn

2000 SL500 Silver
2000 SL500 SOLD
1989 560SL SOLD
1988 560SL SOLD

Last edited by lynns; 08-16-2007 at 03:28 PM.
Reply With Quote
  #23  
Old 08-16-2007, 03:13 AM
skybound's Avatar
Registered User
 
Join Date: Nov 2006
Location: Scotts Valley CA
Posts: 62
The only problem I had with mine was before I purchased it, the top would not lock down in the back. I don't think the previous owner ever had the hardtop off to tell you the truth. I created a thread here asking about the problem before I purchased the car and was told that if the soft top is not used or cycled for long periods of time that this is common that somehow air gets into the hydraulic system and usually if you leave the soft top in the position just before it locks down for the night the system seems to purge itself of air and then works fine. I have had my 99 SL for almost a year now and no problems at all. A great car and lots of fun in the summer. It is great to have such a magnificent car that others only dream of. The most ironic thing though is even though someone paid around 100K for it I purchased in for 20K and in fantastic condition and now I drive a car I only once dreamed of owning. I guess patience and dreams are a good thing.
__________________
1999 SL500 87K
1994 E320 112K
1998 Ford Ranger - the daily driver 274K and no major repairs (an indestructible truck)
1978 Pontiac Trans Am 110K
1977 Pontiac Trans Am 130K
1999 SL500 87K (the garage queen, only out in the summer)
Reply With Quote
  #24  
Old 08-16-2007, 12:17 PM
MB-Dude's Avatar
Proud MB Owner
 
Join Date: Jul 2007
Location: Round Rock, TX
Posts: 215
Quote:
Originally Posted by SunGuy View Post
The enclosed link to a pdf of Approved MB Fluids/Filters up to m/y 2006 may help you; originally produced by MBUSA. FYI...

http://www.benzworld.org/forums/atta...ceproducts.pdf

Bob
Thanks for link, but it seems to be invalid. Can you verify?
__________________
MBCA Member #B012089 (Lone Star Section)
OBK Member #47 (W123 Division)
'96 SL600 (105K) Triple Black - Mein über-Fräulein
'79 240D (292K) Yellow/Saddle - Mein Spielzeug
'01 ML430 (123K) Black/Saddle - Wife's Ride
'94 SL500 (164K) Green/Champagne - Daughter's Dream
'73 450SL - RIP
'86 300E - RIP
'88 420SEL - SOLD
'94 S320 - SOLD
Reply With Quote
  #25  
Old 08-16-2007, 12:40 PM
lynns's Avatar
Registered User
 
Join Date: Mar 2004
Location: So. California
Posts: 295
Quote:
Originally Posted by MB-Dude View Post
Thanks for link, but it seems to be invalid. Can you verify?
Please see http://mywebpages.comcast.net/x0rr0/MBASP.pdf

http://www.benzworld.org/forums/attachments/w210-e-class/133335d1183553992-should-i-change-my-auto-transmission-fluid-after-122k-miles-2006_mbz_factoryapprovedserviceproducts.pdf
__________________
Mit freundlichen Grüßen, Lynn

2000 SL500 Silver
2000 SL500 SOLD
1989 560SL SOLD
1988 560SL SOLD

Last edited by lynns; 08-16-2007 at 01:39 PM.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page