Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-29-2007, 11:06 PM
1990 500SL
 
Join Date: Oct 2003
Location: Hawthorn Woods, IL. USA
Posts: 329
No Problems

Well the thread about top problems, or lack of, lead me to open this one.

Started up the SL today, I parked it in October last year, didn't even add the stabil. Left it with a 3/4 tank of fresh super.
It started right up and ran fine. Last year it ran ragged at first, but ran.

I know what I did was wrong. Usually start it and take it around the block a few times over the winter. This year just been too busy.
I did keep the trickle charger on it, but that was it.

Just my 2 cents worth here.
__________________
KLK, MCSE

1990 500SL

I was always taught to respect my elders.
I don't have to respect too many people anymore.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:26 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page