Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-27-2007, 02:48 PM
Registered User
 
Join Date: Nov 2004
Location: Austin, TX - Hook 'Em
Posts: 112
'80 450SL - How to run AC without Climate Control

Yes, another post on the climate control system.

I have a 1980 450sl that I removed the Servo on a few months back and bypassed it, just to get cold air. However, I hadn't used it yet, and the other day I went to test it out and I was not getting any air whatsoever from the AC unit.

I don't know if this has anythign to do with it, but in the process of doing so, I forgot to unplug the ac amplifier, and when I started the car back up I'm pretty sure I ruined the amp b/c it started smoking.

So my question is, what should I have to do, if anything, to get the AC just to blow cold air, without the climate control system? Does the ac amplifier or any of the other parts have anything to do with it just blowing?

Thanks!
Reply With Quote
  #2  
Old 08-27-2007, 02:56 PM
unkl300d's Avatar
Registered User
 
Join Date: Jul 1999
Location: San Francisco, Ca
Posts: 2,300
Hi as far as I know it seems that the amp does affect the AC. But maybe not.

I had the amp replaced many years ago when my heat went out and besides getting heat back, the AC began to work again.

BUT, recently I had the amp removed because the servo got stuck ON and it was draining the battery.
The AC works (my ac is not extreme cold anyway-but I can feel the difference btw air and AC) and I hear/feel the compressor kick in when it is switched on.

check your fuses for breaks and weak ones.
check your blower fuse. if it is weak or burnt maybe the blower has too much resistance due to age....
good luck

re:'79 300D..same servo etc.
__________________
1979 300D 199 K miles
1995 C280 95 K miles
1992 Cadillac Eldorado Touring Coupe 57K miles
********************
1979 240D 140Kmiles (bought for parents) *SOLD.
SAN FRANCISCO/(*San Diego)
1989 300SE 148 K miles *SOLD
Reply With Quote
  #3  
Old 08-27-2007, 06:12 PM
Registered User
 
Join Date: Nov 2004
Location: Austin, TX - Hook 'Em
Posts: 112
What if I'm not concerned at all with fan speed, etc etc. Basically, Id like it on or off. As simple as that. Does the amp and all that good stuff still come into play?
Reply With Quote
  #4  
Old 08-28-2007, 10:28 AM
meltedpanda's Avatar
Certified Benzaholic
 
Join Date: Mar 2003
Location: Central Ky
Posts: 6,130
I don't think so , I have mine wired direct with a little pull switch, pull out, turns compressor on , push in turns it off, Fan control still works, bypassed the servo mechanisms. I also bypassed heater pods by hooking direct cable to heater valve, pull out heat on , push in heat off
__________________
Ron
2011 Porsche Cayman - Bond,James Bond
99 E320 THE Queen Mary
62 220b - Dolly - Finally my Finny!
72 450SL, Pearl-SOLD
16 F350 6.7 Diesel -THOR
07 Lexus RX 350 - Lexi
14 38HP John Deere 3038E Tractor -Mean Green
84 300SD, Benjamin -SOLD
71 220 - W115-Libby ( my first love) -SOLD
73 280 - W114 "Organspende" Rest in Peace
81 380 SL - Rest in Peace
Reply With Quote
  #5  
Old 08-28-2007, 02:43 PM
unkl300d's Avatar
Registered User
 
Join Date: Jul 1999
Location: San Francisco, Ca
Posts: 2,300
your fan (blower) should operate on different selected speeds without the amp installed.

This does not preclude the AC as being operational.

if you removed the servo completely thereby disconnecting the attached vacuum lines then your vac lines may be a source of some hang up... don't know.
__________________
1979 300D 199 K miles
1995 C280 95 K miles
1992 Cadillac Eldorado Touring Coupe 57K miles
********************
1979 240D 140Kmiles (bought for parents) *SOLD.
SAN FRANCISCO/(*San Diego)
1989 300SE 148 K miles *SOLD
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page