Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-07-2007, 11:27 PM
Registered User
 
Join Date: May 2007
Posts: 4
Question Starting problems 1992 500SL

This car will power up electrically, has a new batttery yet periodically will not turn over. I've tried putting it in neutral thinking neutral safety switch which I still think is a possibility, locking and unlocking thinking itn could be the security system but no luck. It has done this before then went through a period of an entire month when it kicked over just fine, now nothing. What would you do to diagnose the problem further and knowing a neutral safety switch isn't a big cost to replace any particular advice on replacing? Thanks, Jim
Reply With Quote
  #2  
Old 10-08-2007, 12:18 AM
Registered User
 
Join Date: Sep 2006
Location: New Orleans LA
Posts: 93
no start

check out the starter had the same problem on my 300sel I would hit the key and nothing had to have the starter rebuilt
__________________
Keeping 'em Running
1990 300SEL
1994 E320
1989 E300
Reply With Quote
  #3  
Old 10-08-2007, 12:51 PM
Registered User
 
Join Date: Mar 2003
Location: Milwaukee Wisconsin
Posts: 1,150
These cars have an "issue" with the ignition switch going bad. Use the forum search tool for info on the problem and how to fix it. Might not be your problem, but it's something owners of these cars should know about.
__________________
Resistance is Futile.
Reply With Quote
  #4  
Old 10-08-2007, 09:34 PM
aam aam is offline
Registered User
 
Join Date: Sep 2006
Location: California
Posts: 115
Quote:
Originally Posted by tecqboy View Post
These cars have an "issue" with the ignition switch going bad. Use the forum search tool for info on the problem and how to fix it. Might not be your problem, but it's something owners of these cars should know about.

I second that.
Try when car does not start.
Hold Key on start.
Push steering switch in/ out and up/ down.
If car starts is the ignition switch is going south.
Reply With Quote
  #5  
Old 11-21-2007, 02:09 PM
Randy Neefs
 
Join Date: Nov 2007
Location: Canada
Posts: 2
96 sl 320 does not start

i have had similar problem, moving the steering wheel with key on enabled car to start...what do we do to correct problem thanks
Reply With Quote
  #6  
Old 11-22-2007, 01:25 PM
aam aam is offline
Registered User
 
Join Date: Sep 2006
Location: California
Posts: 115
Quote:
Originally Posted by Randy Neefs View Post
i have had similar problem, moving the steering wheel with key on enabled car to start...what do we do to correct problem thanks
Replace the switch.
aam.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page