Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-08-2007, 12:10 PM
Registered User
 
Join Date: Feb 2003
Location: roslyn, LI,NY
Posts: 445
need source for gears for hirschmann antenna

On my 450 sl 1977 the antenna motor works, but mast does not go up or down. Appreciate some info on gears replacement for model 485. hirschmann. Regards, Abe G
Reply With Quote
  #2  
Old 10-08-2007, 03:33 PM
Bob's your uncle
 
Join Date: Aug 2007
Location: Charlotte, NC
Posts: 76
If it was me I am not sure that I would bother about just replacing the gears. You can buy replacement antennas from Performance for less than $200 (-15% if MBCA member).

Have you taken the antenna apart? Are you sure that it is the gear? The gear is pretty simple and I donít see it break. It might be the drive beltÖ.
Reply With Quote
  #3  
Old 10-08-2007, 04:18 PM
Registered User
 
Join Date: Jul 2003
Location: Ocean Isle Beach, NC
Posts: 2,443
Walter is your man.

http://www.geocities.com/odemer@sbcglobal.net/
__________________


Len
'59 220S Cabriolet-SOLD and living happily in Malta
'83 240D 351,500 miles original owner-SOLD
'88 560SL 41,000 miles - being parted out
https://sites.google.com/site/mercedesstuff/home
'99 E300 turbo 219,500 miles
'03 SLK320 40,000 miles - gave to my daughter
'14 Smart electric coupe 19,000 miles
'14 Smart electric cabriolet 13,500 miles
Reply With Quote
  #4  
Old 10-08-2007, 06:47 PM
ScottinSoCal's Avatar
Registered User
 
Join Date: Oct 2006
Posts: 252
I've had that problem with both my 450SLs and in both cases the only thing I had to replace was the antenna mast. It costs less than $30, goes in quickly and I haven't had a problem since I replaced them.

On my 78 I tried to clean and lubricate the old mast and it kind of worked for a little while, but I eventually just got the new mast and it's been flawless since then. On my 75 the old antenna was seized solid and the motor wouldn't grab the new mast so I took the box apart and found it 1/2 full of dirt, sand and crap. I cleaned it out, lubricated everywhere with some good lithium grease and fed the new mast in. It's worked beautifully ever since then.
Reply With Quote
  #5  
Old 10-08-2007, 09:58 PM
Registered User
 
Join Date: Mar 2003
Location: Convent Station, NJ
Posts: 755
The mast whip and two large nylon gears are common problems. The gears go when the antenna sits for a while and the mast is forced up when the telescopic segments stick together. The lobe on one of the gears breaks off easily.

Ebay sells "Generic" Hirshmann electric replacement antennas for about $40 and the mast/whip assembly for a bit less. Replacement parts can also be purchased from www.antennaworld.com.
__________________
Rick

'85 380 SL (sold)
'85 Carrera Flatnose
'71 280 SL Signal Red/Cognac

Last edited by RickM; 10-09-2007 at 09:42 PM.
Reply With Quote
  #6  
Old 10-08-2007, 10:17 PM
waybomb's Avatar
Registered User
 
Join Date: Nov 2002
Location: St. Joe, MI; Manitowoc, WI
Posts: 1,553
Raul at Antennaworld has helped me alot with my antenna needs. Ha has scored parts and a new KE cheap! He's the go to guy


"raul@antennaworld.com"
__________________
Thank You!
Fred
2001 E430 Sport, 204,000 miles
1997 C280 Sport, 144,000 miles
1991 300SL, 189,000 miles
1987 420SEL, 149,000 miles
1986 190e 2.3 16v, 151,000
1968 W30 442, 78,000 miles
1988 46' US1 Cougar, 3 supercharged 572's
http://s4.photobucket.com/albums/y145/waybomb/
Warming the globe, 24 cylinders at a time
And I want a 126 wagon! Point me to one!
Reply With Quote
  #7  
Old 10-09-2007, 12:03 PM
Registered User
 
Join Date: Feb 2003
Location: roslyn, LI,NY
Posts: 445
Thanks for referals and help antenna repair

I apprciate he time and consideration of your referals and am following up on same. Will keep you all advices. Thanks again, Abe G
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:31 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page