Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-15-2007, 06:33 PM
MB, love..hate..love..
 
Join Date: Apr 2003
Location: NB Canada
Posts: 1,173
Where is the interior temp sensor on a 1986 560SL?

Well, I'm a new 1986 560SL owner, and here we go with the problems. The climate control system is in really bad shape. I have a 1985 380SE with what looks like the same system, but the interior temperature sensor on this car is up on the windshield header, by the rear view mirror. I once had a 1975 450SE, and it had a sensor on the top of the dash.

A previous owner has installed a dash-cap, and I can't find the sensor anywhere. So, can anyone tell me for certain if the sensor is covered up under the dash-cap? I'd hate to rip it out for nothing, but the system sure isn't gonna work right if it's buried under this cap. Or is it somewhere else?
__________________
1986 560SL
2002 Toyota Camry
1993 Lexus
Reply With Quote
  #2  
Old 10-15-2007, 07:09 PM
Registered User
 
Join Date: Mar 2006
Location: Upstate NY
Posts: 212
The vent is located on the top of the dash, in the center. To get to the sensor (thermistor) you will need to access it from the glove box area. Remove the glove box (pushpin fasteners). There is a foam tube that goes up to the sensor. Often the foam is dry rotted and gone. This tube draws air in across the sensor. There are wires with a connector under the dash. The plastic vent is two pieces, and has a part that comes off from the underside. Don't try to pry the louver top part, it has to come apart below before it comes up and out. The plasic part holds the sensor, and the air tube comes in on the plastic nozzle. I replaced my sensor (got it from Fastlane above). I used clear plastic tubing from Home Depot to replace the foam tube.
Reply With Quote
  #3  
Old 10-15-2007, 07:23 PM
MB, love..hate..love..
 
Join Date: Apr 2003
Location: NB Canada
Posts: 1,173
Thanks for the response! I suspected it was up there, buried beneath the cap. I just hope the cap isn't glued down too well, as it will have to come out to cut the hole for the sensor. I just can't beleive how stupid some people are, installing those things like that!
__________________
1986 560SL
2002 Toyota Camry
1993 Lexus
Reply With Quote
  #4  
Old 10-15-2007, 08:22 PM
Registered User
 
Join Date: May 2006
Location: Caroline alberta Canada
Posts: 26
Hey Don i had a real good laugh when i read your opening statement --here we go with the problems -ha ain't that the truth---Louis - nice home page by the way.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page