Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-17-2007, 03:55 PM
Registered User
 
Join Date: Oct 2007
Location: Greater Metropolitan Beaverdam VA
Posts: 2,464
560SL rich running after warmup

This is a repair report.

Symptoms: Good start and running when cold with a higher than normal idle. After warm, intermittent rough running and near stall from a hot restart. Rich running evidenced by black smoke, odor from cat convertor and spark plug color..

Repair: Replace engine temperature sensor that provides input to fuel injection computer. This sensor is located in intake manifold on left (driver's) side just under front edge of air cleaner. Must remove air cleaner to access. Sensor has a green top and two wires attached.

Source: Logic (heat related running fault) and research location and description on ALLDATA. Recommend ALLDATA to any amatuer wrench.

Result: Normal running and idle under all engine temperature conditions.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page