Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-20-2008, 03:29 PM
Registered User
 
Join Date: Feb 2008
Posts: 5
Check engine - Oxygen Sensor 99 SL500

Hi to All,

I have the check engine light coming on and off on my SL500 recently.
I had the fuel filter, air filters and spark plags replaced last month.
It has 91K miles on it.
I had the car scanned today, and had the following codes stored:
PO305, PO306, PO307, PO308 (cylinder 5,6,7,8 misfired)

Also PO150 which is a front oxigen sensor in bank 2. I like to know if that is the driver side as I was told or not.

Also PO300 which is a random misfire and PO410 which is a malfunction in the secondary air injection system.

I was thinking about to have the driver side oxygen sensor replaced first.
Can that cause the misfire? What else should I have checked?
One more thing I should mention. If I floor the gas padal, it looks like half the engine shuts off and loose the power. If shut off the engine and restart, all cylinders are working.

Any help would be highly appreciated.

Thanks!
Reply With Quote
  #2  
Old 02-20-2008, 11:26 PM
aam aam is offline
Registered User
 
Join Date: Sep 2006
Location: California
Posts: 115
Quote:
Originally Posted by brpt50 View Post
Hi to All,

I have the check engine light coming on and off on my SL500 recently.
I had the fuel filter, air filters and spark plags replaced last month.
It has 91K miles on it.
I had the car scanned today, and had the following codes stored:
PO305, PO306, PO307, PO308 (cylinder 5,6,7,8 misfired)

Also PO150 which is a front oxigen sensor in bank 2. I like to know if that is the driver side as I was told or not.

Also PO300 which is a random misfire and PO410 which is a malfunction in the secondary air injection system.

I was thinking about to have the driver side oxygen sensor replaced first.
Can that cause the misfire? What else should I have checked?
One more thing I should mention. If I floor the gas padal, it looks like half the engine shuts off and loose the power. If shut off the engine and restart, all cylinders are working.

Any help would be highly appreciated.

Thanks!
How was the car before you did all that work?
Cylinders 5678 is the left driver side.
I can think of a few things.
1. ign. coil.
2. ign. wires
3. ign. rotors
4. check the 02 sensor wires for tuching the drive shaft.
5. platinum plugs, not a good idea.
Check and come back.
Regards.
aam.
Reply With Quote
  #3  
Old 02-21-2008, 07:31 AM
Registered User
 
Join Date: Feb 2008
Posts: 5
Smile

Hi AAM,

Thank you very much for your response. The car was running fine up until about a month ago. Then the check engine light came on and the idle was rough sometime. Then the light went out. I had an oil change and had the fuel filter replaced. Then the check engine light came back on and off. Now it comes on almost every day, and flashes sometime when the car wants to die. I have Bosch platinum spark plugs installed. I will have the sensor wire and the coil checked, and let you know what we find. Thanks again!

Brian
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:13 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page