Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-09-2008, 07:29 AM
Registered User
 
Join Date: Nov 2007
Posts: 16
lack of power on low end

hi all I have a 1991 300 sl 24 v the runs well but at pull away it starts miss firing and feels if it is going to swich off sometimes on top end it holds back but at idle it is fine. I have changed the fuel pumps, filters, injectors, seals, plugs, plugs wires, set up the CO2. I dont know were to look.Please help.

__________________
Gareth Brockman
Reply With Quote
  #2  
Old 03-09-2008, 12:02 PM
Registered User
 
Join Date: Mar 2003
Location: Milwaukee Wisconsin
Posts: 1,150
Have you looked at the distributor and the rotor? Also the solenoid / actuator which changes the valve timing?
__________________
Resistance is Futile.
Reply With Quote
  #3  
Old 04-03-2008, 12:41 PM
Registered User
 
Join Date: Nov 2007
Posts: 16
yes they are all fine

__________________
Gareth Brockman
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page