Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-15-2009, 09:53 PM
Registered User
 
Join Date: Nov 2007
Posts: 13
'96 SL500 transmission "slip", lose 5th gear

Had an unpleasant experience today: Going around a sharp turn, sensed the engine rev, as tho the wheels were slipping or lost traction. Subsequently, would not shift into 5th gear. After shutting down and restarting, shifting became normal, but again experienced the slipping effect on the same sharp curve.

Anybody have any ideas what might be going on?

Cheers,
Half
Reply With Quote
  #2  
Old 10-16-2009, 02:34 AM
lynns's Avatar
Registered User
 
Join Date: Mar 2004
Location: So. California
Posts: 295
Check the fluid level.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page