Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-05-2009, 03:20 PM
Registered User
 
Join Date: Jul 2008
Location: Faison, NC
Posts: 7
Anyone.....1981 380SL Transmission Slippage ????

Hi guys! Problems again. Transmission started slipping on takeoff.....shifts fine after first upshift from dead stop.

Changed fluid including convertor, new filter and added Lucas transmission additive as well (two bottles). Fluid at correct level.

First day after fluid change it was alot better. Getting worse ever since. From stop it takes revving to 1500-2000 rpm for 15-20 seconds before it will catch and pull away from a stop. After upshift it shifts fine.

Any analysis or advice?? Thanks!!

Last edited by Doug Lewis; 01-08-2010 at 11:56 AM. Reason: No response.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page