PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Mercedes-Benz SL Discussion Forum (http://www.peachparts.com/shopforum/mercedes-benz-sl-discussion-forum/)
-   -   Lamp control module (http://www.peachparts.com/shopforum/mercedes-benz-sl-discussion-forum/271856-lamp-control-module.html)

greyhoundj 02-20-2010 07:57 AM

Lamp control module
 
Greetings,
I am new to your forum and have just purchased a 1998 MB SL500. I am having trouble with the "Bulb out" warning light on the dash. I have replaced all the bulbs in the vehicle with MB bulbs on the advice of my mechanic. The dash light will flash and go out. Sometimes it will remain off for a few days and then come back on and go on and off. I am wondering if it might be the "Lamp Control Module" being flakey. This module is 345.00 from the Dealer and I don't want to replace it if that is not the problem. Any advice on the above would be greatly appreciated.

Jim1998

sokoloff 02-20-2010 05:04 PM

Not sure if this is an issue with the SL, but on the 210 chassis and the SLK's, there was/is an issue with the brake light sockets being bad and/or losing contact. A search should bring up info on that. Also, are you sure that the license plate lights are okay and not losing contact? Are there any lights actually out when the indicator comes on? Check closely - those license plate lights are often overlooked. I sure wouldn't jump at a new control module just yet.

amosfella 02-20-2010 05:07 PM

I"m sure that cleaning the contacts of the lamp control module and putting some electrical grease on them won't hurt anything.

greyhoundj 02-21-2010 09:49 AM

Lamp Control Module
 
Thanks to you both for your information.
To Sokoloff:
I have replaced the licence plate lights and they do work. When the light on the dash comes on,I stop and check to see if any lights are out. As of this time I have not found any out. I have checked them all(doors,Brakes Parks Etc.)I took the tail light holders out and cleaned all the contacts and made sure all the bulbs worked.I founf a loose ground wire which I fixed,but this made no difference.
To Amosfella
If I new how to get this module out I would check it.I know where it is but am really nervous about taking the Fuse box apart. The car is in storage now and has to go to the Dealer to have the Trans oil and filter changed when I put it in service again. At this time I will get the Dealer to do as you suggest. Thank you both for the in formation.

Jim1998


All times are GMT -4. The time now is 07:26 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website