PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Mercedes-Benz SL Discussion Forum (http://www.peachparts.com/shopforum/mercedes-benz-sl-discussion-forum/)
-   -   Warm up regulator ?? (http://www.peachparts.com/shopforum/mercedes-benz-sl-discussion-forum/272729-warm-up-regulator.html)

samonline 03-04-2010 10:19 AM

Warm up regulator ??
 
I was checking the fuel pressure thru the WUR on my 1976 Sl ,by jumping the fuel relay 30 87 and car is not running .The fuel pressure comes out 70 psi , is that normal or it can be adjusted . Also when I turn the ignition on , the RPM needle move all the way to max and go back to zero, But car still not starting. Does this car has a "crankshaft sensor". By the way car does not start,I have installed a new battery, new plugs, new injectors, new ignition and distributor,sparks very good. where shall I start. Thanks Sam ( I am bringing this up again ,so we all can learn from this wonderful Forum , That fix a lot of problems on my other Mercedes) . Thanks Sam

ctaylor738 03-04-2010 01:59 PM

You are testing by connecting the gauge between the fuel dist. and the warm-up regulator, correct? You shut the valve on the WUR side and measure system pressure. Then you open the valve to measure control pressure.

70 psi system pressure is good. Your control pressure with at cold engine should be 21-24 psi and warm about 55 psi. If you have 70 psi cold, the car probably won't start. Why? Because the high pressure will not allow the air sensor plate to deflect enough for the piston in the FD to move, hence no fuel.

The most common cause of this is the mesh filter in the WUR inlet is clogged. You can remove the fitting and fish the filter out with a pick and clean it. There are several layers of mesh and they all need to be clean.

You can try cranking the engine while someone pushes the sensor plate down about half an inch with a stick. Dont get your face close because you may get a backfire!

samonline 03-09-2010 11:03 PM

I cleaned the wur very well, I have noticed that the pressure bar goes from 1.5 to 2.0 max , by jumping the relay 30 , 87 . Car still not starting . Where should I go from here.Thanks

ctaylor738 03-12-2010 12:22 PM

Control pressure should rise from 1.5, which is fine, to around 3.8. You may not have enough fuel pressure. What system pressure are you getting? That's measured with the valve on the WUR side closed.

Can you put a timing light on the car and see if you are getting spark around TDC on #1?

Is there any possibility that the timing chain has jumped and you have bent valves and no compression on the left bank?


All times are GMT -4. The time now is 04:28 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website