Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-16-2017, 12:13 PM
engatwork's Avatar
busy
 
Join Date: May 2000
Location: Soperton, Ga. USA
Posts: 12,249
Got a beautiful 72 350SL in shop

Working through a few miscellaneous items on it. Initially it would not run over 2200 rpm. Repaired leaking fuel line at engine and fuel filter. Also resolved issue with worn out throttle linkage preventing full throttle. It is now accelerating as it should be.

Now on to the a/c. It has been converted to r134 refrigerant and the freon side of things is doing like it is supposed to. The blower is running but I am not getting anything out of the center vents like I should and I'm not sure the fan is blowing as hard as it could be. I'm thinking about pulling the blower and see what kind of build up is at inlet to evap. I do see that center vent damper flap is not opening up but need to review the "settings" of the levers, etc.... to see if they are properly positioned. It looks like I remove the inst cluster to get to the actuator side of the damper door. Thoughts/comments?
__________________
Jim
Reply With Quote
  #2  
Old 07-16-2017, 11:15 PM
tyl604's Avatar
Registered User
 
Join Date: Feb 2008
Location: Atlanta, GA
Posts: 3,213
How about a pic.
Reply With Quote
  #3  
Old 07-17-2017, 11:55 AM
meltedpanda's Avatar
Certified Benzaholic
 
Join Date: Mar 2003
Location: Central Ky
Posts: 6,116
you can access through dash instrument pod opening and removal of glove box.
may have to remove steering wheel
__________________
Ron
2011 Porsche Cayman - Bond,James Bond
99 E320 THE Queen Mary
62 220b - Dolly - Finally my Finny!
72 450SL, Pearl-SOLD
16 F350 6.7 Diesel -THOR
07 Lexus RX 350 - Lexi
14 38HP John Deere 3038E Tractor -Mean Green
84 300SD, Benjamin -SOLD
71 220 - W115-Libby ( my first love) -SOLD
73 280 - W114 "Organspende" Rest in Peace
81 380 SL - Rest in Peace
Reply With Quote
  #4  
Old 07-17-2017, 12:48 PM
Graham's Avatar
Registered User
 
Join Date: Nov 2004
Location: Ontario, Canada
Posts: 3,409
Quote:
Originally Posted by engatwork View Post
Working through a few miscellaneous items on it. Initially it would not run over 2200 rpm. Repaired leaking fuel line at engine and fuel filter. Also resolved issue with worn out throttle linkage preventing full throttle. It is now accelerating as it should be.

Now on to the a/c. It has been converted to r134 refrigerant and the freon side of things is doing like it is supposed to. The blower is running but I am not getting anything out of the center vents like I should and I'm not sure the fan is blowing as hard as it could be. I'm thinking about pulling the blower and see what kind of build up is at inlet to evap. I do see that center vent damper flap is not opening up but need to review the "settings" of the levers, etc.... to see if they are properly positioned. It looks like I remove the inst cluster to get to the actuator side of the damper door. Thoughts/comments?
Presumably you have an owners manual? The climate control lever positions are hard to remember. This might help:
__________________
Graham
85 300D,72 350SL, 98 E320, Outback 2.5
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page