Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-24-2018, 11:09 PM
Ron59b
 
Join Date: Aug 2007
Location: Richmond, Virginia
Posts: 471
1991 Mercedes SL500 Intermitten No Starting When Warm????

Good evening all

A friend of mine has a 1991 SL500 that I am considering purchasing. The car has 98,000 miles and ran great aabefore he starting issue. Hes narrowed it to possible issues with the coil or the ECU.

He said that when attempting to start the car, if the dash icons along the base of the cluster aren't on or lighted, the car will not start.

He also said that once the engine is warm, the car will not start intermittently. Can some tell me where to start? What might be the most likely culprit?

Thank you

Ron
__________________
Reply With Quote
  #2  
Old 04-25-2018, 01:18 AM
Registered User
 
Join Date: Oct 2004
Posts: 3,229
Ignition switch.
__________________
90 300TE 4-M

Turbo 103, T3/T04E 50 trim
T04B cover .60 AR
Stage 3 turbine .63 AR
A2W I/C, 40 LB/HR
MS2E, 60-2 Direct Coil Control
3" Exh, AEM W/B O2
Underdrive Alt. and P/S Pulleys,
Vented Rear Discs, .034 Booster.
3.07 diffs 1st Gear Start

90 300CE 104.980
Milled & ported head, 10.3:1 compression
197 intake cam w/20 advancer
4 ignition advance
PCS TCM2000, built 722.6
600W networked suction fan
Sportline sway bars
V8 rear subframe, Quaife ATB 3.06 diff
Reply With Quote
  #3  
Old 04-25-2018, 10:39 AM
Ron59b
 
Join Date: Aug 2007
Location: Richmond, Virginia
Posts: 471
Good morning and thanks for the reply. Are you referring to the electrical connector for the ignition switch, or the entire lock assembly? How difficult is it to replace?
__________________
Reply With Quote
  #4  
Old 04-25-2018, 07:05 PM
Registered User
 
Join Date: Jan 2012
Posts: 7,179
The dash lights not working helps but we need a bit more info.

Define " car won't start " in terms of:

Turn key, engine cranks but won't run.

Turn key, engine won't crank.

You could have a ignition sw problem for the no dash lights and a fuel system issue for a no run warm.

I bought a SL parts car a while back. In the car was a dealer receipt for repairs.

Service writer: Customer states , " Car won't start "

Tech : car started 2 dozen times over the day.

Service writer: customer states , " Key won't turn "

List of ig lock, other parts and labor.
Reply With Quote
  #5  
Old 04-26-2018, 10:23 AM
Ron59b
 
Join Date: Aug 2007
Location: Richmond, Virginia
Posts: 471
Thank you 97 SL 320 for your reply. When turning the key, the engine does turn over, but will not start. I hope this is helpful?

Ron
__________________
Reply With Quote
  #6  
Old 04-26-2018, 08:02 PM
Registered User
 
Join Date: Jan 2012
Posts: 7,179
The next step is to attach a test light to the ignition coil power supply and see if it lights up.

I'd also probe other circuits that need powered up with key on or when cranking.

As post 2 states , maybe ignition switch needs replaced.
Reply With Quote
  #7  
Old 04-26-2018, 09:08 PM
Ron59b
 
Join Date: Aug 2007
Location: Richmond, Virginia
Posts: 471
Thank you
__________________
Reply With Quote
  #8  
Old 05-16-2018, 01:06 AM
Registered User
 
Join Date: Feb 2009
Posts: 9
I too have had the same symptoms as this but without the dash lights not going. Mine was the Crank Position Sensor. I got from here and put it in. 30 minute job. Problem solved. Worth doing as it was under a hundred bux and it seems to be a common thing with all types of cars.
Reply With Quote
  #9  
Old 04-03-2019, 09:59 PM
Ron59b
 
Join Date: Aug 2007
Location: Richmond, Virginia
Posts: 471
The car is now running after replac ou ng the following items:

1. Ignition switch.
2. Crank sensor.
3. Fuel pumps.

Now the car is having an issue with intermittent high and low idle. The car surges on it's own. Sometimes the idle is so low the car cuts off. I also get the smell of fuel sometimes. Any suggestions?

Thanks

Ron
__________________
Reply With Quote
  #10  
Old 04-04-2019, 10:17 PM
Ron59b
 
Join Date: Aug 2007
Location: Richmond, Virginia
Posts: 471
I forgot to mention the car did sit for sometime before I purchased it.
__________________
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:05 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page