Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-02-2018, 01:21 PM
Registered User
 
Join Date: Aug 2017
Posts: 7
560sl Fan Blower/AC Question

I have an '88 560SL. Wondering what is going on with the Blower/AC system. System is fully charge, has new compressor, dryer, high pressure and fan switch. Cools great when the system is on. Issue is that it shuts off and comes back on randomly. When is shuts off, both the AC compressor clutch and blower turn off. Then back on and cools great, then back off.....

I have take the AC controller apart and re-soldered suspect spots, did the same on the blower control unit. Pin #6 was discolored, re-soldered that spot on the circuit board.

Reassembled it all and no change. If I turn key on, blower will run forever. It only acts up when the engine is running. Any ideas? Could the Temperature Regulator box (aluminum covered one on fire wall) be the issue?

thanks
Reply With Quote
  #2  
Old 09-02-2018, 02:56 PM
Diseasel300's Avatar
Registered User
 
Join Date: May 2016
Location: Texas Hill Country
Posts: 4,666
Does the R107 still have the 2-piece HVAC control in '88? I'd expect something that's causing both compressor and fan to misbehave to be in the pushbutton unit or a wiring fault. If you still have the original aluminum fuse feeding the pushbutton unit, replace it with a brass or copper one, the aluminum ones can develop tiny fractures that can cause all sorts of irritating problems as they age.
__________________
'11 Honda Accord EX - "The Daily" 64K
'83 500SL Euro - "The Money Pit" 116K
'91 350SD - "The Diseasel Jr." 168K
'86 300SDL - "The Diseasel" 189K (Totaled 1/31/19)
The Diseasel Thread - Everything You Didn't Know You Wanted To Know
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page