Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-11-2019, 06:01 PM
Registered User
 
Join Date: Apr 1999
Location: N.E. Ohio
Posts: 155
Angry 99 sl hardtop removal

Put my hard top back on today. Problem is driverside rear latch did not engage. Now I can't remove hard top. Is there a way to resync latches or manually release top to reinstall. I can hear cylinder working but top does not release.
__________________
Donwo
1999 SL 500 Sport (30K miles)
1998 E320 (SOLD)
1989 560SL (SOLD)
1987 300E (TOTALED)
1986 300E (SOLD)
1984 300SD (SOLD)
Reply With Quote
  #2  
Old 10-11-2019, 07:44 PM
Registered User
 
Join Date: Jan 2012
Posts: 7,474
I'd manually unlatch the top and try again or just manually latch it.

The front latches are a T27 or T30 ish Torx, the rear latches need a long thin 10 mm open end that I think you slide in the area about 12 inches from the door. There are instructions in the owners manual.
Reply With Quote
  #3  
Old 10-12-2019, 05:44 PM
Registered User
 
Join Date: Apr 1999
Location: N.E. Ohio
Posts: 155
I have the tool. I can unlatch the locks on windshield header. I can not locate where to unlatch the rear latches. I can not find info in owners manual. This is for 1999 model year. Earlier models had plastic trim on both sides near trunk hinge where to insert tool. My car does not. What am I to look for near the trunk hinges.

Thanks,
__________________
Donwo
1999 SL 500 Sport (30K miles)
1998 E320 (SOLD)
1989 560SL (SOLD)
1987 300E (TOTALED)
1986 300E (SOLD)
1984 300SD (SOLD)
Reply With Quote
  #4  
Old 10-14-2019, 07:09 AM
oldsinner111's Avatar
love all animals
 
Join Date: Nov 2008
Location: bristol,tn
Posts: 5,654
maybe a youtube vid?
__________________
my lifetime,I'v seen the world go to hell,and america, a facist country.we need a 7 mile wide asteroid hit, to save earth from mankind
Reply With Quote
  #5  
Old 10-16-2019, 03:53 PM
Registered User
 
Join Date: Apr 1999
Location: N.E. Ohio
Posts: 155
I now have the hardtop off. When I raise the soft top everything works correctly except the red top light on console remains on. When I lower the soft top the light goes out.
Not sure what the problem is. Is there a sync procedures? Any ideas appreciated
__________________
Donwo
1999 SL 500 Sport (30K miles)
1998 E320 (SOLD)
1989 560SL (SOLD)
1987 300E (TOTALED)
1986 300E (SOLD)
1984 300SD (SOLD)
Reply With Quote
  #6  
Old 10-16-2019, 05:29 PM
Registered User
 
Join Date: Jan 2012
Posts: 7,474
The last operation to lock the soft top when it is raised / last operation to lock the hard top is the problem. I'd be looking for a limit switch not making.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:06 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page