Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-06-2002, 06:04 PM
Byronjc
Guest
 
Posts: n/a
Wink 560 sl hard top

The hard top on my 560 sl sits badly. It seems that the seal underneath is missing on passenger side. There is a gap between the top and the car body on left side, but the top sits right on the car on the right. The seal is there and not damaged, but maybe compressed? When I drive the car I hear a thump or bump coming from the top when I hit road bumps. Any thoughts?
Reply With Quote
  #2  
Old 08-07-2002, 04:11 PM
ericdee's Avatar
Registered User
 
Join Date: May 2001
Location: Los Angeles, CA
Posts: 497
Try this link

Can't get the Hardtop on Tight!
__________________
Eric, 1983 500 SL
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page