Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-13-2002, 10:11 PM
Registered User
 
Join Date: Jun 2001
Posts: 41
93sl 600.

Get the smell of gasoline on startup particularly when a cold start.Have looked carefully for leaks but none seen.. Ideas anyone?. Mechanic suggests purge mechanism. Car has 32k miles and I feel it is somewhat soon for that to be giving out
Reply With Quote
  #2  
Old 08-13-2002, 10:26 PM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
I had a similar year SL500 doing the same thing. Take the cover off that's under the fuel filter and pump and make sure that there isn't a small leak at that area, that's where is was on this one, I just needed to replace the newer style crimp on hose clamps with the "normal" worm-gear type, fixed it right up.

Gilly
Reply With Quote
  #3  
Old 08-14-2002, 12:32 AM
Registered User
 
Join Date: Jun 2001
Posts: 41
93 600SL

Fuel filter is where? I think I see something like it by right rear wheel but no obvious cover on same.Is that it? Incidently when will shop manual be available on this model (93SL600).
Reply With Quote
  #4  
Old 08-14-2002, 02:17 AM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
Since this model (R129) went out of production about a year ago, it will be some time before Mercedes offers any manual on disc or otherwise for it.

Yes, the fuel pump and filter assembly is under the car ahead of the right rear wheel area, it should have a black plastic shield underneath it.

Gilly
Reply With Quote
  #5  
Old 09-20-2002, 12:13 AM
Registered User
 
Join Date: Jun 2001
Posts: 41
Checked fuel pump and changed filter. Still got smell and appears to be coming from left wheel well also rear of car which may be related to fan action. Anyone any other thoughts ?.
Reply With Quote
  #6  
Old 09-23-2002, 09:27 PM
urbanassault
Guest
 
Posts: n/a
I smelled something similar to raw fuel

.... Seriously though, I was opening up the ol' 94' SL500 the other day, came back around the block and parked. The Valet sayed "they sure are putting alot of detergents in the gas now days" and just then the detergents coming from the cats had a very similar smell to raw fuel. I noticed it a couple of times after that. Seems like Texaco smells stronger than others.
Or , could be,your catalyst has not warmed up to operating temp yet ....
Reply With Quote
  #7  
Old 09-24-2002, 11:08 PM
bareftr02
Guest
 
Posts: n/a
is your car also hard to start. ive had two mechanics say the fuel injectors may leak causing a gas smell
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page