Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-26-2002, 06:57 PM
Registered User
 
Join Date: Dec 2001
Location: Bay Area, CA
Posts: 51
Angry 560sl hardtop ?stuck?

The rear latch on my wife's 560sl hardtop doesn't seem to want to let go. We've tried variations on setting and releasing the locking levers, etc. When the locking lever is set to the locked position it is still pulling the rear pin down. Any tricks to getting it loose? I am guessing there is a jammed or sticky part in the catch but I don't know, having never looked at it. I really don't want to pull the seat, if that is what is required.

Thanks all.
__________________
John C
1987 560SL 109,000 miles
2001 E320 103,000 miles
2007 E350 32,000 miles
Reply With Quote
  #2  
Old 08-26-2002, 08:25 PM
ericdee's Avatar
Registered User
 
Join Date: May 2001
Location: Los Angeles, CA
Posts: 497
Try this link:

84 SL Hard Top Stuck - rear bullet. Please help
__________________
Eric, 1983 500 SL
Reply With Quote
  #3  
Old 08-27-2002, 04:45 PM
Registered User
 
Join Date: Sep 2001
Location: Austin, TX
Posts: 563
That's the same general way that I released mine, but I just used a long regular screwdriver. Down the passenger side of the center pin. Took 3 people, two to hold the top and one to slide in behind the front seats to use the screwdriver.

When you get it out, there's a plastic connector near the driver's side convertible hinge, but in the bottom of the hatch, that you need to tighten. I've forgotten whether it turns clockwise or counter-clockwise, but you should be able to figure it out. Of course, it's possible that the entire cable needs to be replaced.
__________________
Mike Heath
1988 560SL Black/Palomino
1988 300SEL Black Pearl/Burgandy
1984 500SEC Anthracite Grey/Palomino
Reply With Quote
  #4  
Old 08-29-2002, 02:52 PM
Registered User
 
Join Date: Dec 2001
Location: Bay Area, CA
Posts: 51
Smile Thanks

Thanks for your assistance with this. Funny, I tried that search but it didn't work as well as your link.

Happily, we got the roof off without these procedures. However, I now know to tighten the cable before putting the roof back on.
__________________
John C
1987 560SL 109,000 miles
2001 E320 103,000 miles
2007 E350 32,000 miles
Reply With Quote
  #5  
Old 08-29-2002, 04:29 PM
Registered User
 
Join Date: Jul 2001
Location: Orange County, CA
Posts: 35
John,

I had the same problem with my SL. That plastic nut always slips. What I did, after adjusting was wrap electrical tape behind the nut to hold it in place and secured the tape with a zip pull.

So far, it has lasted.

Good luck.
__________________
Marvin
1983 380 SL
Reply With Quote
  #6  
Old 08-31-2002, 10:39 AM
Registered User
 
Join Date: Jul 2002
Posts: 18
What is a "Zip Pull" ?
Reply With Quote
  #7  
Old 08-31-2002, 09:11 PM
ericdee's Avatar
Registered User
 
Join Date: May 2001
Location: Los Angeles, CA
Posts: 497
I think he's referring to a zip tie.


__________________
Eric, 1983 500 SL
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page