Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-19-2002, 12:14 PM
Registered User
 
Join Date: Aug 2002
Location: south-east missouri
Posts: 75
new sl emblem

Can any one tell me how to get the old emblem off so I can put a new one on? Do you just pry it up? Do the little clips that the pins go into, fall off or they attached to the hood? thanks dairel
Reply With Quote
  #2  
Old 10-19-2002, 01:07 PM
4NDELIT's Avatar
Registered User
 
Join Date: Sep 2002
Location: Dublin, CA
Posts: 887
I heard that dental floss works... actually that's how I heard they steal them! but I haven't personally tried it
Reply With Quote
  #3  
Old 10-19-2002, 01:53 PM
larrysiny
Guest
 
Posts: n/a
Smile Emblem

Just use a small screw driver to get underneath the emblem(you might want to put a rag on the hood so as not to scratch the paint). As soon as the emblem lifts up wiggle it out with your fingers. The new one should have new plastic plugs that insert into the hood. Put the new plugs in and align the pins on the emblem and push down....Thats all there is to it.

Larry 560SL
Reply With Quote
  #4  
Old 10-19-2002, 02:07 PM
Registered User
 
Join Date: Aug 2002
Location: south-east missouri
Posts: 75
sl emblem

The new one which is an orginal me part, doesn't have the plastic plugs. Will the old ones stay in place, I can't reach them or will they fall off inside the hood when I pull the pins out? thanks alot dairel
Reply With Quote
  #5  
Old 10-19-2002, 02:13 PM
larrysiny
Guest
 
Posts: n/a
Emblem

The plugs should stay in place as they are wider at the top so pressure can be put on them. The dealer can supply you with new ones if you loose them. It's easy .

Larry
Reply With Quote
  #6  
Old 10-19-2002, 04:26 PM
Registered User
 
Join Date: Aug 2002
Location: south-east missouri
Posts: 75
sl emblem

I got it replaced thanks alot, once I found out that the plugs would stay in place it was a snap. I just didn't want to find out the hard that they would not. The old one looks black and the new one is blue, and what with it raining I just when ahead and put on another coat of wax. thanks dairel
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page