PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Mercedes-Benz SL Discussion Forum (http://www.peachparts.com/shopforum/mercedes-benz-sl-discussion-forum/)
-   -   No Power to Fuel Pump (380SL) (http://www.peachparts.com/shopforum/mercedes-benz-sl-discussion-forum/75189-no-power-fuel-pump-380sl.html)

Al Perez 09-18-2003 12:11 PM

No Power to Fuel Pump (380SL)
 
85 380SL died while driving, Local Mechanic states the fuel pump is not getting power but cannot pinpoint cause. Need help on possible causes!!

maheath 09-18-2003 02:31 PM

Besides the obvious electrical stuff like corroded connectors and a wiring short, I'd look at the fuel pump relay. It's the one that supplies the power to the fuel pump. If your mechanic didn't know that, I'd find a new mechanic.

Assuming it's in the same location as my 560SL, remove the glovebox lining, and WAY back you'll see three relays. I think the front two are idle control and A/C. Anyway, the fuel pump relay is behind one of them. Small hands are going to help here. You can test it by jumping pins 7 & 8 (you should check the service manual to be sure). That should route power straight to the pump. You can open up the relay to see if any solder joints are cracked. Even if you resolder any joints, you should consider replacing the fuel pump relay if that's causing your problem.

maheath 09-18-2003 02:33 PM

BTW, in Austin, try Ben's Workshop on 5th St.


All times are GMT -4. The time now is 06:21 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website