PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Mercedes-Benz SL Discussion Forum (http://www.peachparts.com/shopforum/mercedes-benz-sl-discussion-forum/)
-   -   380SL Timing Chain Noise Question? (http://www.peachparts.com/shopforum/mercedes-benz-sl-discussion-forum/75412-380sl-timing-chain-noise-question.html)

ezrider 09-21-2003 04:50 PM

380SL Timing Chain Noise Question?
 
I have a 1985 380SL with 105K miles on it. The timing chain tensioner was replaced at 75K miles and the timing chain and tensioner (again) was replaced at 80K miles.

Now there is a noise that sounds like a loose timing chain sometimes, but not all the time, on a cold startup. I never hear the noise on warm startups. What should I be looking for to cure this? Is it easy to inspect the timing chain rails for damage?

Thank you.

ezrider 09-22-2003 03:24 PM

From what I read here the 1985 380SL has a double chain, that being the case is the chain noise I'm hearing of concern?

Thank you.

Heriberto Rosas 09-22-2003 04:42 PM

I own a 1983 Euro 500SL and have the same problem. They changed the chain and tensioner two months ago and keeps doing the same thing. Now the tec says he is going to change the oil pump because maybe its not pumping enough oil at startup. What i am going to do before that is put a thinner oil, maybe 30 or 40.


All times are GMT -4. The time now is 07:19 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website