Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-25-2003, 10:22 PM
mike122470@aol.
Guest
 
Posts: n/a
99 sl500 heated seats

I checked all fuses under hood & in trunk all ok. Lites go on forboth seats but no heat in either. Please help. mike122470@aol.com
Reply With Quote
  #2  
Old 10-05-2003, 01:25 AM
Registered User
 
Join Date: May 2001
Location: Las Vegas, Atlanta
Posts: 669
Not difficult to troubleshoot

The system consists of the pair of switches in the center console, a control unit located under the passenger footrest, and a pair of heating elements in each seat. You will need a voltmeter to check supply voltages to the controller, the wiring between the switches and the controller, and the outputs to the heating elements. Post a reply if you want specifics....
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page