PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Mercedes-Benz SL Discussion Forum (http://www.peachparts.com/shopforum/mercedes-benz-sl-discussion-forum/)
-   -   Need help with 560SL electrical problems (http://www.peachparts.com/shopforum/mercedes-benz-sl-discussion-forum/76004-need-help-560sl-electrical-problems.html)

Solarlady 09-29-2003 01:34 AM

Need help with 560SL electrical problems
 
I just bought a 1989 560sl and am hoping that someone can help me with a few electrial problems:

I found the wire which connects to the heated window washer nozzles has been cut. Would this effect anything else?

My inside courtesy lights also do not work when drivers door is opened(I replaced the bulb and still not working) Right door works fine.

Also my anti-theft factory alarm does not work (Replaced both fuses in auxillary fuse box and checked all fuses in main fuse box.)

And last...my gauge that shows outside temperture is not working. (goes all the way to end as soon as ignition key is turned, returns to zero when key is off)

Could any of these problems be related?
Would appreciate any help on these issues.

Thanks!

DavidSoine 09-30-2003 11:50 PM

The door switches provide a ground to both the courtesy lamps and the anti-theft alarm (ie they trigger the alarm.)

Does the anti-theft work at all? Try opening the hood with the vehicle locked - or just about anything else, apparently. The anti-theft wiring diagram covers at least 4 pages in the service manual. Do all the locks work? Try locking the car from the passenger side?

I'm generating these ideas from looking at the schematics...sorry I don't know the common problems, etc.

best & good luck,

Dave

maheath 10-01-2003 03:05 PM

First, if you haven't replaced all of the fuses, you should. You can't always tell by looking if the fuse is still good. I had several odd electrical problems with my 560SL when I bought it. Most of them went away when I replaced all of the fuses. I still had the aluminum strip fuses. The new ones are copper. Costs about $10.

Also, some people like to disable the alarm. I believe that it's done at the control box, but I don't know how.

The courtesy light sounds like the driver's door switch is having a problem. Cheap to replace.

For the temperature gauge, look at this thread:
http://www.peachparts.com/shopforum/diesel-discussion/204502-citrus-flush-causes-all-hard-white-chalk-my-cooling-system.html

Solarlady 10-02-2003 01:17 AM

Thanks Mike & Dave,
I checked and replaced all the fuses when I first got the car.
As far as the anti-alarm system goes, I tried locking the car and then reaching in and opening the door from the inside(on both doors) and crawling into car to put foot on brake...none of this set off the alarm. However when I had it in the shop, the mechanic said that it went off when he locked the car and left for a few minutes( he had the hood open); when he came back the alarm was going off. Go figure...
All key works in all the locks and they all work fine.
I will check out the threads on the temp sensor.
Thanks!


All times are GMT -4. The time now is 10:01 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website