Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-10-2003, 09:43 AM
Eddie Gilmartin's Avatar
Registered User
 
Join Date: Sep 1999
Location: Dublin, Ireland
Posts: 183
ADS hydro-pneumatic suspension failure

My '90 R129 500SL has ADS suspension. It seems to have stopped working. An independent mechanic has diagnosed that the electric pump in the boot/trunk is not functioning. He also spoke about a mechanical pump in the engine bay, but has not assesed its condition. A main dealer replaced the two rear "spheres" about twelve months ago. Driving the car is like driving on bricks. The nose bobs up and down like a seesaw. The heigth adjustment is not working. The hard/soft setting appears to still do something. I am not confident that anyone over here knows how to repair and setup this system, including the main dealers.
Any body familiar with this system?
Know which parts to replace?
Know the part numbers?
Hoping there is an expert out there. Please help...
__________________
'66 W100 600 SWB
'05 W463 G55K AMG
'91 W126 500SEL
'93 W463 300GDL
'84 W460 280GES
'83 W460 300GDL
'66 W111 220SEb Coupe
'58 W121 190
'58 W180 220S
Have previously owned '99 SL600, '99 ML320, '79 450SLC, '79 450SEL 6.9 x 2, '68 600, '91 190E 1.8, '90 190E 2.0, '85 190, '90 500SL, '92 500SEL, '97 E300Turbodiesel, '91 300D, '72 280S, '82 300D, '81 300SD, '85 230E, '56 220a and I'm sure I'm forgetting some.
Reply With Quote
  #2  
Old 10-14-2003, 05:22 AM
Eddie Gilmartin's Avatar
Registered User
 
Join Date: Sep 1999
Location: Dublin, Ireland
Posts: 183
Come on guys! Somebody must know something about this system. I'm on my knees here...
Reply With Quote
  #3  
Old 10-16-2003, 06:14 AM
Registered User
 
Join Date: Jan 2003
Posts: 55
Well, I am by no means an expert, but I have dropped about $3000 into the ADS in my car, so here are some observations. First to check are the gas spheres. There are four, one for each wheel, and mine were all bad.
This is the main cause of the harsh ride. The spheres are relatively cheap,
I think around $280 total to replace all four. But every other component on this sytem is priced as if it were made of plutonium.

I paid $960 plus $300 labor to replace a leaky distribution block. The block looks like a brake master cylinder, but with no moving parts. $960. I paid $1350 to replace a leaking leveling valve. There are three others that I have not touched.

If you really like this system, which I obviously do, take a run at getting those spheres changed. It's cheap and it may solve the problem. If not, I would yank the whole thing out and install conventional springs and shocks. This can be done for about $1600, there was a post about this on either this site or the mbworld.org forum. That is my plan if another four figure repair should crop up.

Don't get discouraged, this system is complicated but not impossible to fix, just decide how much it is worth to you, and remember you can always bail out and just put in regular shocks and springs.
Reply With Quote
  #4  
Old 10-20-2003, 02:35 PM
Eddie Gilmartin's Avatar
Registered User
 
Join Date: Sep 1999
Location: Dublin, Ireland
Posts: 183
Thanks for the tips. At long last I find someone who has this system. I've faxed your comments to the mechanic. I'll let you know how I we get on.
Reply With Quote
  #5  
Old 10-21-2003, 02:48 AM
Registered User
 
Join Date: Jan 2003
Posts: 55
This might help

Reply With Quote
  #6  
Old 10-21-2003, 10:23 AM
Eddie Gilmartin's Avatar
Registered User
 
Join Date: Sep 1999
Location: Dublin, Ireland
Posts: 183
Wow. Where did you get that? I've just been to visit the mechanic. He showed me a pump under the spare wheel, dead center of the well in a protective cage. He says it is the electric air compressor, and that it's dead. I can't find it on your diagram. Any thoughts?
Reply With Quote
  #7  
Old 10-21-2003, 02:23 PM
Registered User
 
Join Date: Jan 2003
Posts: 55
The pump under the spare wheel in the trunk is for the soft top mechanism, has nothing to do with the ADS.
Reply With Quote
  #8  
Old 10-23-2003, 02:26 AM
Eddie Gilmartin's Avatar
Registered User
 
Join Date: Sep 1999
Location: Dublin, Ireland
Posts: 183
Uh oh.
Reply With Quote
  #9  
Old 10-24-2003, 06:18 AM
Registered User
 
Join Date: Jan 2003
Posts: 55
My car had the same exact symptoms you describe. Is there fluid in the reservoir? Mine was dry. Just replacing the spheres and filling up with fluid might solve the problem, but then some very expensive leaks might appear. Or maybe not, when did the system last work?
Reply With Quote
  #10  
Old 10-27-2003, 01:47 PM
Eddie Gilmartin's Avatar
Registered User
 
Join Date: Sep 1999
Location: Dublin, Ireland
Posts: 183
Seemed to deteriorate over the summer. Some days good, other days crap. Finally, crap all the time. Fluid is fine. Looks brand new, as it should considering MB changed the rear spheres just over a year ago. Visited the car again on Friday. Now the front end is down on the tyres. Mechanic says he disconnected pump in the trunk and it sank down in about ten minutes. He is still convinced that pump is part of the ADS. He was to replace it with a used part over the weekend. Let's see what happens next. Thanks for your continued interest.
Reply With Quote
  #11  
Old 10-28-2003, 12:49 AM
Registered User
 
Join Date: Jan 2003
Posts: 55
Good luck with it. Save the old pump, because if your top still worked, then it's okay and can be reused or sold on ebay. I would suggest that you go to www.alldatadiy.com. For $24.95 per year you will get access to a large variety of factory diagrams like the one I posted above. You can look at the ADS diagrams there yourself, as well as the ones that clearly show the under tire pump as part of the soft top and rollbar hydraulic system. Anyway, good luck and I hope all goes well with your car.

Last edited by Roger65; 10-28-2003 at 01:01 AM.
Reply With Quote
  #12  
Old 10-30-2003, 06:12 PM
Eddie Gilmartin's Avatar
Registered User
 
Join Date: Sep 1999
Location: Dublin, Ireland
Posts: 183
Signed up to www.alldatadiy.com . Very impressed. Found the pump under the spare wheel. It's the soft-top hydraulic unit. I've printed the diagram. Must pay my car a visit.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page