Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-26-2003, 12:30 PM
Registered User
 
Join Date: Oct 2001
Location: Cornwall UK
Posts: 119
SL 320 nonstart HELP!

I have just replaced the AC evaporator in my wifes 1994 SL 320 but after refitting the dash etc the car refuses to crank or run, it appears to be a alarm imobolisation fault. The car is a UK spec with factory fitted alarm system I have checked for any missed connections but I cant see anything not connected! Battery power was maintained but obviously the dash cluster and ignition switch was disconnected. The alarm can be armed and disarmed normally but a few seconds after turning the ignition on the central locking locks the doors, can anyone help?
Reply With Quote
  #2  
Old 10-26-2003, 12:45 PM
Registered User
 
Join Date: Sep 2003
Location: Dallas, Tx
Posts: 701
Check

Is there power to all your accessories? what happens when you turn the key to position 2? does the dash light up? Whew! what a lot of work to do just to not have the car start! If your dummy lights come on, then you know the ignition is working, I would try disconnecting the battery for a bit to reset everything and then trying it. If that doesn't work, check all the connections, go through everything and check it. I fixed my rearview mirror in my SL320 (was loose) and when I put it back together it would not run, I pinched a wire when I re-assembled, I never thought that something in the reaview mirror would cause this, but the alarm receiver is in there so Just check everything again. Good luck!
Regards,
Brian
Reply With Quote
  #3  
Old 10-26-2003, 02:11 PM
Registered User
 
Join Date: Oct 2001
Location: Cornwall UK
Posts: 119
Hi Brian, thanks for your reply everything works in pos 2 apart from the goddam engine, all dummy lights accesories etc. I even tried shorting the starter feed the engine will then crank but not run. Thanks Linds
Reply With Quote
  #4  
Old 10-27-2003, 04:51 AM
Registered User
 
Join Date: Oct 2001
Location: Cornwall UK
Posts: 119
Angry SL 129 320 Non start HELP!

Can anyone please advise on noncrank or run after evaporator replacement the alarm system locks and unlocks OK but locks the car itself if the ignition is turned on. I have tried disconnecting the alarm unit and the battery without successs!. The car is a 94my with the red/green lights in the handles. I tried shorting the starter the engine then cranks but doesnt run there is power out of the ignition switch. Please can anyone suggest any other area to look, i have retraced all connections etc that were removed in AC repair are there any significant connections I should recheck? Regards Linds
Reply With Quote
  #5  
Old 10-27-2003, 09:54 AM
Registered User
 
Join Date: Sep 2003
Location: Dallas, Tx
Posts: 701
Linds,
I am not entirely familiar with the wiring in these cars, but I did look at my SL320 and it seems like there is an issue between the car and the engine (quite aparant huh?) so I am sure you have checked all the wires leading to the engine, the control unit under the hood behind the passenger side firewall, and the main engine harness leading from the firewall to the engine. There are a whole bunch of wires back there under the interior air intake too, as I am sure you know since you had the entire thing apart. I will ask my pal that works at Park Place what he thinks. Good luck!
Brian
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:38 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page