Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-22-2004, 12:43 PM
Registered User
 
Join Date: Mar 2004
Location: Pittsburgh, PA
Posts: 56
500SL top alarm and sensors

Alarm indicating top not locked went off on me (never heard it before, took a minute to figure out what it was!) over weekend. Clicked top mechanism button and it quit. Top was firmly fastened, by the way.
Had rear window assembly fixed, and following that the same thing happened but multiple times - but it did quit until I hit a bump. Seems to be quiet for the moment. Any ideas about what's causing this somewhat erratic behavior?

__________________
Bill in Pittsburgh
_____________

1993 500SL
Reply With Quote
  #2  
Old 07-26-2004, 01:34 PM
Registered User
 
Join Date: May 2001
Location: Las Vegas, Atlanta
Posts: 670
There are switches mounted to the top latches which signal the top controller that all is secure. One of your switches may be faulty or incorrectly adjusted. You should be able to diagnose this by putting the top controller in diagnostic mode. You will need no special tools.

1) Close the soft top manually or automatically. Have the windows up. The correct position for the roll bar depends on the version of your soft top controller. Let's assume it is the raised postion. If this is incorrect, a fault code for the roll bar lowered switch will falsely appear later in the test -- no big deal.

2) Erase as many diagnostic codes from the soft top controller as possible. This is very simple to do and is explained here.

3) Switch off the ignition.

4) Install a jumper between sockets "1" and "3' of the "X11/12" connector located behind the passenger-side footrest. This connector is shown in the photo below.

5) Switch the ignition on.

6) Push the soft top button forward for two to four seconds as if you were trying to close the top.

7) Read out and record any diagnostic codes for the soft top controller.

8) Remove the jumper from the connector X11/12.

9) Lower the top, roll bar, and windows either manually or automatically.

10) Open the soft top compartment cover and move it to its raised position. I recommend doing this manually. Use the special Mercedes wrench to release the latches if necessary.

11) Switch the ignition off.

12) Re-install the jumper on X11/12.

13) Switch the ignition on.

14) Push the soft top button rearward for two to four seconds as if you were trying to open the top.

15) Read out and record any diagnostic codes for the soft top controller as explained in the thread noted in "2" above. Any codes you find will identify your problem. If you email them to me or post your findings back here, I can interpret them for you.

16) Remove the bridge.
Attached Thumbnails
500SL top alarm and sensors-delete.jpg  

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page