Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > ML, GL, G-Wagen, R-Class, Unimog, Sprinter

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-11-2016, 03:45 PM
Registered User
 
Join Date: May 2016
Posts: 2
Windshield wipers not working? 09' GL450

I currently have an 09' GL450 that a week or so ago the wipers started working intermittently and then stopped in a good rain storm on the highway. As you can imagine that was a very scary situation with my family in the car. Anyways, I have taken the vehicle to a local indy that works on European cars and he has had the vehicle for a couple days now. He just called and informed me that the issue is that it needs a new front SAM module. He mentioned he was surprised that we didn't get any SRS errors on the dash as that generally points quickly to a SAM module.

He did mention upon his tests, the error code that was showing up in the diagnostic was a stuck motor BUT he said that he was not seeing the wiper signal becoming activated when turning the knob on the wiper stalk. The rear wiper works fine and 100% of the time when requested, it is only the front wipers that do not work anymore on any of the settings. The fuses checked out and the cluster (wiper stalk) checked out he said.

I have a feeling that since I have the stalk working fine, and no SRS errors that it may NOT be the SAM module but a relay like you had an issue with. I'll certainly test the theory with someone in the passenger seat, I don't believe I've had someone in the passenger seat when trying this other than the initial time they stopped working. While that's probably shooting in the dark, it is worth a try.

I'm not looking forward to spending the $1,000 to replace the front SAM module right off the bat without bouncing this off of a few people online. Any thoughts?

Now that I have the vehicle back in my possession this afternoon, I'm going to check the fuses and relay (which I assume he already did but for my piece of mind). I found a fuse diagram but I can't seem to find a relay diagram anywhere online. Does anyone have that?

Thanks!
Andy
Reply With Quote
  #2  
Old 05-12-2016, 12:11 PM
ILUVMILS's Avatar
Senior Member
 
Join Date: Sep 2002
Posts: 2,593
Ok, I know this may sound like a stupid question but did he check for power at the motor while activating the switch??? It's unlikely the switch has failed at ALL wiper speed positions. FWIW, wiper motors fail far more frequently than SAM's on GLs'...........

I have no clue as to what he means concerning the SRS light either???
Reply With Quote
  #3  
Old 05-13-2016, 07:05 AM
Registered User
 
Join Date: May 2016
Posts: 2
Smile

I believe he said he checked the motor and it checked out. I'm going to assume that he did his due diligence there but I of course wasn't there. I will have to ask him if he did. The wiper motor could be the culprit.

I'm going to check the relays as I'm not sure if he knew there were 2 front relays and a single in the rear.

The problem I'm having though is finding a relay diagram, I can only seem to find one for fuses online. Since you clearly are versed in MB, do you have any suggestions on where one would be?

Thanks!
Andy
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page