Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > General Discussions > Off-Topic Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-12-2006, 11:04 AM
Registered User
 
Join Date: Apr 2006
Posts: 23
Question Heated seats problem

Dear Experts,
I have 1 560SEL 1991 (W126) and 1 S420 1994 (W140). Both cars have heated seats problem, the light on the switch are on when I press it but there is no heat on the seats.
For my 1991 560SEL, I just replace the fuse, this fuse is flat fuse outside the fuse box but very close to it toward the front of the car... Then it comes back to normal. Now my 1994 S420 have the same problem but I can not locate this fuse, is there any fuse like this for W140 car and where is it located?

Thanks,

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page