Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > General Discussions > Off-Topic Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-25-2007, 08:51 PM
Unregistered Abuser
 
Join Date: Jul 2005
Location: Eau Claire WI
Posts: 968
The beater without a heater...

Allright, on my $75 '95 ford Escort, the heater quit working....

When I got the car on thursday, it worked, only if u had the knob between two of the positions... Now, it doesnt blow any air, in any position. The radiant heat comming from the vents is warm, but nothing else happens. When I push the AC buttion, the AC controler lights up, but no air...


Any help would be greatly appreciated... My uncle's STRONGLY considering getting this car for my 16 y/o cousin who'll be getting her lisance soon, provided everything required for driving works

~Nate

__________________
95 Honda Shadow ACE 1100.
1999 Plymouth Neon Expresso. 2.4 swap, 10.5 to 1 comp, big cams. Autocross time attack vehicle!
2012 Escape, 'hunter" (5 sp 4cyl)
Reply With Quote
  #2  
Old 02-25-2007, 09:20 PM
TheDon's Avatar
Ghost of Diesels Past
 
Join Date: Oct 2005
Posts: 13,217
no heater? wear a jacket.. jk jk

the blower motor could be on the fritz or dead.. how are the fuses. (also look at the fuse make sure both sides of the plug are good with a trust multimeter ya dig?)
Reply With Quote
  #3  
Old 02-25-2007, 09:23 PM
Unregistered Abuser
 
Join Date: Jul 2005
Location: Eau Claire WI
Posts: 968
Hey I knew a ****head like you'd pipe up
I'm not bothered with the cold, it's just that the windshield frosting up's an issue...

Havent checked fuses, it's on my list of stuff to do...

I'll be doing that now, but, the AC light works when I press the AC button, so I'd ass-u-me the blower's on the same fuse...

I'm pulling it into the garage after I get done posting

~Nate
__________________
95 Honda Shadow ACE 1100.
1999 Plymouth Neon Expresso. 2.4 swap, 10.5 to 1 comp, big cams. Autocross time attack vehicle!
2012 Escape, 'hunter" (5 sp 4cyl)
Reply With Quote
  #4  
Old 02-25-2007, 09:35 PM
TheDon's Avatar
Ghost of Diesels Past
 
Join Date: Oct 2005
Posts: 13,217
nah the jacket thing is from a VW buddy... old beatles had heat worse than what your experiencing..

seriously see what the blower is doing thats more or less the root of the problem. Even find where it is located and give it a kick or too might work
Reply With Quote
  #5  
Old 02-25-2007, 09:54 PM
kmaysob's Avatar
Registered User
 
Join Date: Nov 2003
Location: mesa az
Posts: 1,673
sounds like the control switch. (you say it only worked inbetween two positions)
__________________
have no worries.....President Obama swears "If you like your gun, you can keep it
Reply With Quote
  #6  
Old 02-25-2007, 10:07 PM
Jim B.'s Avatar
Who's flying this thing ?
 
Join Date: May 2006
Location: N. California./ N. Nevada
Posts: 3,611
Quote:
Originally Posted by TheDon View Post
... old beatles had heat worse than what your experiencing..
I've heard the same, about those, the heater output at full blast is like the breath of a small mouse on your leg.
__________________
1991 560 SEC AMG, 199k <---- 300 hp 10:1 ECE euro HV ...

1995 E 420, 170k "The Red Plum" (sold)

2015 BMW 535i xdrive awd Stage 1 DINAN, 6k, <----364 hp

1967 Mercury Cougar, 49k

2013 Jaguar XF, 20k <----340 hp Supercharged, All Wheel Drive (sold)
Reply With Quote
  #7  
Old 02-26-2007, 12:10 AM
Unregistered Abuser
 
Join Date: Jul 2005
Location: Eau Claire WI
Posts: 968
fuses are good...

now what?

O, I detailed the engine bay
Nice and clean
~Nate
__________________
95 Honda Shadow ACE 1100.
1999 Plymouth Neon Expresso. 2.4 swap, 10.5 to 1 comp, big cams. Autocross time attack vehicle!
2012 Escape, 'hunter" (5 sp 4cyl)
Reply With Quote
  #8  
Old 02-26-2007, 09:36 AM
Unregistered Abuser
 
Join Date: Jul 2005
Location: Eau Claire WI
Posts: 968
TTT
any ideas?
__________________
95 Honda Shadow ACE 1100.
1999 Plymouth Neon Expresso. 2.4 swap, 10.5 to 1 comp, big cams. Autocross time attack vehicle!
2012 Escape, 'hunter" (5 sp 4cyl)
Reply With Quote
  #9  
Old 02-26-2007, 09:51 AM
TheDon's Avatar
Ghost of Diesels Past
 
Join Date: Oct 2005
Posts: 13,217
did you locate the blower motor and kick it yet?

if kicking it doesnt work get your 3/8th ford wrench and go at it... jk jk
Reply With Quote
  #10  
Old 02-26-2007, 10:04 AM
Unregistered Abuser
 
Join Date: Jul 2005
Location: Eau Claire WI
Posts: 968
I'll take a look at it during shop, but I didnt see anything last night...

~Nate
__________________
95 Honda Shadow ACE 1100.
1999 Plymouth Neon Expresso. 2.4 swap, 10.5 to 1 comp, big cams. Autocross time attack vehicle!
2012 Escape, 'hunter" (5 sp 4cyl)
Reply With Quote
  #11  
Old 02-26-2007, 03:28 PM
kmaysob's Avatar
Registered User
 
Join Date: Nov 2003
Location: mesa az
Posts: 1,673
check the switch?
__________________
have no worries.....President Obama swears "If you like your gun, you can keep it
Reply With Quote
  #12  
Old 02-26-2007, 03:32 PM
Registered User
 
Join Date: Oct 2006
Posts: 254
Quote:
Originally Posted by Nate View Post
Hey I knew a ****head like you'd pipe up
I'm not bothered with the cold, it's just that the windshield frosting up's an issue...

Havent checked fuses, it's on my list of stuff to do...

I'll be doing that now, but, the AC light works when I press the AC button, so I'd ass-u-me the blower's on the same fuse...

I'm pulling it into the garage after I get done posting

~Nate
It's pretty unlikely that the HVAC blower is on the same circuit as the A/C compressor.
Reply With Quote
  #13  
Old 02-26-2007, 04:12 PM
Larry Delor's Avatar
What, Me Worry?
 
Join Date: Jun 1999
Location: Sarasota, Fl.
Posts: 3,112
I would check the switch first.

Beetles with non-German heat exchangers gave less heat than those with.
__________________
It is a truism that almost any sect, cult, or religion will legislate its creed into law if it acquires the political power to do so. Robert A. Heinlein


09 Jetta TDI
Reply With Quote
  #14  
Old 02-26-2007, 04:16 PM
MattBelliveau's Avatar
Gotta another one...
 
Join Date: Jun 2005
Location: NE Ohio
Posts: 1,685
If it's the switch, and you are looking for a cheap fix, try a toggle. All or nothing
__________________
1989 300E 144K
Reply With Quote
  #15  
Old 02-28-2007, 01:57 PM
Unregistered Abuser
 
Join Date: Jul 2005
Location: Eau Claire WI
Posts: 968
I got the heat to "kinda" work... Ford SUCKS. they put too small of an end on the power wire for the blower, so it's a common issue of them melting. I guess, but whatever. Someone had this happen, so they just stripped the end...


The black/blue power wire was just taped to the blower, with the hopes that the end would connect to the metal peice in there... I put a new .20 end on it.

I have heat in positions 1-3, but nothing on 4. The vent knob wont go all the way to the right, I have about halfway of movement on it... The defrost setting is on the far right

Any ideas on that one?
tks alot
~Nate

__________________
95 Honda Shadow ACE 1100.
1999 Plymouth Neon Expresso. 2.4 swap, 10.5 to 1 comp, big cams. Autocross time attack vehicle!
2012 Escape, 'hunter" (5 sp 4cyl)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page