Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > General Discussions > Off-Topic Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-20-2007, 10:34 PM
Monomer's Avatar
Colonel Blitz
 
Join Date: Jan 2006
Location: Detroit, MI
Posts: 836
OT: I'm stumped (GF's 92 chevy cavalier rs electrical)

I cant seem to figure this out...


Her blinkers stopped working (rather she's never had them) I replaced all lamps (all turn signal were blown - as were some taillights) and it work for about an hours (as I give it back to he it stops)

t went from having no signals, to having some electrical gremlins. When the brake is depressed, the lights in the car dim (like, the radio and whatnot) and her taillights/fogs come on. The high-beam light is always on (but dim) whenever the lights are on.



It seams relays and switches/fuses are spread randomly around under the hood - and none are labeled. What should I be looking for?
__________________
-1983 VW Rabbit LS Diesel (5speed, VNT/Giles build)
Reply With Quote
  #2  
Old 06-20-2007, 11:19 PM
Registered User
 
Join Date: Mar 2006
Posts: 632
i'd say your looking for a bad ground.either a dash ground or the ground cable from battery to engine,engine to body.
Reply With Quote
  #3  
Old 06-20-2007, 11:29 PM
Registered User
 
Join Date: Oct 2004
Posts: 482
Quote:
Originally Posted by Monomer View Post
It seams relays and switches/fuses are spread randomly around under the hood - and none are labeled. What should I be looking for?
A lake. Deep one.
Reply With Quote
  #4  
Old 06-21-2007, 12:10 AM
iwrock's Avatar
roflmonster
 
Join Date: Nov 2003
Location: Hella NorCal
Posts: 3,312
Quote:
Originally Posted by Monomer View Post
What should I be looking for?
A diesel W123/W124 for her.
__________________
-Justin

01 Honda S2000 - dogs dd
07 MB ML320 CDI - dd
16 Lexus IS250 - wifes dd

it's automatic.
Reply With Quote
  #5  
Old 06-21-2007, 12:17 AM
Registered User
 
Join Date: Sep 2001
Posts: 690
Check the following

Some ideas:

There should be a ground connection near the left kick panel E brake pedal area. You will have to be on the drivers floor looking up to see it, 10MM head w/black wires and a star washer. Make sure it is tight.

Look for damaged wires under the carpet where the drivers left foot rests. Check the flasher push button. If it is in partially it can cause many problems, just push it in and pull it back out.

Look for a bad connection in the trunk on the left side where the tail/brake lamp harness plugs in to the harness going forward to the passenger compartment

Lastly try another t/signal switch, just plug it in at the bottom of the column as a test before completely installing it
Reply With Quote
  #6  
Old 06-21-2007, 04:20 PM
Monomer's Avatar
Colonel Blitz
 
Join Date: Jan 2006
Location: Detroit, MI
Posts: 836
Quote:
Originally Posted by justinwrock View Post
A diesel W123/W124 for her.
Volvo 240 wagon.


already got the car picked out, I just cant afford it at this point.




thanks sb, I'll look into it.
__________________
-1983 VW Rabbit LS Diesel (5speed, VNT/Giles build)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page