Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > General Discussions > Off-Topic Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-26-2007, 12:54 AM
DMZ DMZ is offline
Dexter
 
Join Date: Oct 2007
Location: Oregon
Posts: 2
'89 300e trans problem

I have a 1989 300e with automatic transmition that shifts smooth through all gears until i go about 30 miles and the tranny really warms up. Then it doesnt want to shift into 4th gear (drive). When I get to 40 to 50 mph I put it into neutral and quickly put it back into drive it usually will shift into drive. After the car sits and cools down then it shifts fine again until it gets really warmed up. I just had the tranny drained along with the converter and put in new oil and conditioner to see if that helped and it shifts really smooth until it warms up. Any suggestions?????

Reply With Quote
  #2  
Old 10-26-2007, 06:35 AM
Botnst's Avatar
What knockers!
 
Join Date: Jun 2003
Location: There castle.
Posts: 41,599
Take it to "Tech Help". They know stuff about cars over there, especially MB.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:07 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page