Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > General Discussions > Off-Topic Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-11-2009, 03:17 AM
cmac2012's Avatar
Renaissance Dude
 
Join Date: Dec 2004
Location: Berkeley, CA
Posts: 15,419
Anybody have problems with T Mobile?

I'm more or less liking my new Sony-Ericcson phone with T Mobile and the web connection is a good deal.

But one thing is driving me nuts and may influence my long term relationship with T-Mobile/SE. It's getting to where about half of my incoming calls show the caller's name or number on the screen but no voice is available, nor do they hear mine. I call back immediately and everything works.

The SF area is a sort of high tech capital so if it doesn't work here, not good.

Or might it be the phone that's doing this? Customer service says they have a hard time identifying intermittent issues.

Maybe I'll go back to Verizon one day, after all. Crap.
__________________
cmac

1986 300SDL, 315K
1987 BMW 325i, 440K
Reply With Quote
  #2  
Old 09-11-2009, 07:06 AM
Medmech's Avatar
Gone Waterboarding
 
Join Date: Feb 2007
Posts: 117
Quote:
Originally Posted by cmac2012 View Post
I'm more or less liking my new Sony-Ericcson phone with T Mobile and the web connection is a good deal.

But one thing is driving me nuts and may influence my long term relationship with T-Mobile/SE. It's getting to where about half of my incoming calls show the caller's name or number on the screen but no voice is available, nor do they hear mine. I call back immediately and everything works.

The SF area is a sort of high tech capital so if it doesn't work here, not good.

Or might it be the phone that's doing this? Customer service says they have a hard time identifying intermittent issues.

Maybe I'll go back to Verizon one day, after all. Crap.
Its your phone if it was the network the issue would have been widespread.
Reply With Quote
  #3  
Old 09-11-2009, 07:30 AM
G-Benz's Avatar
Razorback Soccer Dad
 
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
I have T-Mobile.

Had none of the problems you've experienced.

However, different issues arose depending on the "flavor" of phone I chose during a particular contract period. So methinks it's the phone.
__________________
2009 ML350 (106K) - Family vehicle
2001 CLK430 Cabriolet (80K) - Wife's car
2005 BMW 645CI (138K) - My daily driver
2016 Mustang (32K) - Daughter's car
Reply With Quote
  #4  
Old 09-11-2009, 12:53 PM
cmac2012's Avatar
Renaissance Dude
 
Join Date: Dec 2004
Location: Berkeley, CA
Posts: 15,419
Quote:
Originally Posted by Medmech View Post
Its your phone if it was the network the issue would have been widespread.
That's what I'm thinking. The guys at Radio Shack say they haven't heard similar complaints about T Mobile, though I might have to use the grain of salt for what they say.

Over at Howard Forums, other owners of the phone are pretty happy with it, I'll have to see what kind of satisfaction I can get with it - new one maybe.
__________________
cmac

1986 300SDL, 315K
1987 BMW 325i, 440K
Reply With Quote
  #5  
Old 09-11-2009, 12:57 PM
cmac2012's Avatar
Renaissance Dude
 
Join Date: Dec 2004
Location: Berkeley, CA
Posts: 15,419
Quote:
Originally Posted by G-Benz View Post
I have T-Mobile.

Had none of the problems you've experienced.

However, different issues arose depending on the "flavor" of phone I chose during a particular contract period. So methinks it's the phone.
The thought occurred to me before I bought it that Sony-Ericsson phones don't seem to be at the top of the heap in terms of reputation. OTOH, Ericsson's been around for a while and SONY ought to bring some heft to the table.
__________________
cmac

1986 300SDL, 315K
1987 BMW 325i, 440K
Reply With Quote
  #6  
Old 09-11-2009, 03:29 PM
pawoSD's Avatar
Dieselsüchtiger
 
Join Date: Oct 2004
Location: Grand Rapids, MI
Posts: 15,050
Most likely a phone issue. The better and more $$ of a phone you buy, the less weird issues you will have...I've learned this through experience. LG and Motorola make excellent phones.....IMHO.
__________________
-diesel is not just a fuel, its a way of life-
'15 GLK250 Bluetec 80k - mine - (OC-80,500)
'17 Metris(VITO!) - 11k - wifes (OC-17k)
'01 E320 Wagon - 159k - mine (OC-160,000)
'01 E320 - 172k - dad's (OC-171,500)
'07 E350 Wagon - 131k - dad's (OC-132,500)
'01 SL500 - 50k - dad's (OC-52,000)
'09 E350 4matic Sedan - 140k - Brothers (OC-141,500)
Reply With Quote
  #7  
Old 09-11-2009, 03:34 PM
powerpig's Avatar
In Memory of the Sam Man
 
Join Date: Feb 2006
Location: Guntersville, AL
Posts: 649
Remove the tin foil hat and the problem should go away.
__________________
99 ML320
94 SL600
92 SL500
95 E320 Cabriolet
87 560SEC
86 300SDL Grease Car
80 380SLC Euro

13 Fiat Abarth
02 Maserati Spyder Cambiocorsa
00 BMW Z3
90 Rolls Royce Silver Spur
80 Ferrari 308 GTSI
88 Jaguar XJS12 H&E Edition
99 Land Rover Discovery
Reply With Quote
  #8  
Old 09-11-2009, 03:35 PM
iwrock's Avatar
roflmonster
 
Join Date: Nov 2003
Location: Hella NorCal
Posts: 3,312
How many days have you had the phone?


Does it only happen in a certain area, or in multiple areas?



My thought is that the problem lies in the phone. I would take it back to radioshack or sprint and see if they will replace it.
__________________
-Justin

01 Honda S2000 - dogs dd
07 MB ML320 CDI - dd
16 Lexus IS250 - wifes dd

it's automatic.
Reply With Quote
  #9  
Old 09-11-2009, 03:50 PM
Medmech's Avatar
Gone Waterboarding
 
Join Date: Feb 2007
Posts: 117
Quote:
Originally Posted by powerpig View Post
Remove the tin foil hat and the problem should go away.
don't forget about the channeling electrodes.
Reply With Quote
  #10  
Old 09-11-2009, 06:34 PM
cmac2012's Avatar
Renaissance Dude
 
Join Date: Dec 2004
Location: Berkeley, CA
Posts: 15,419
Nah, the electrodes are brand new.

This phone makes me feel like an idiot. Today, I had an issue with my fuel pump, damn thing was leaking fuel onto the roadway, but only when the engine was running. So I shut it down and get a tow via 21st Century free roadside assistance. BTW, if you want to change to 21st, let me know, I'll give you my acct. #, you say I recommended you, and I get a $50 gas card.

Good company, IMHO. Good rates and virtual AAA included.

Anyway, I NEED to get the call back from roadside assistance to set up the tow. The phone rings - once again, dead air. So I press the send button again, and a message comes up "retrieving call." (?!?) Sure enough, the call comes through. So, oh boy, if I hit send twice, the call works, or so I think cause I did that with the next 2 calls and got the same message and the call came through.

This can't be right. I found a Sony Ericsson trouble shooting page that I'll get to later, but at least I may have found a way around the problem for now.

My mom visited me recently, Verizon had just mailed her a new phone (rural area), a tiny LG. I helped her with the manual and figuring the damn thing out. A surprisingly good phone, but the navigation button was too small. I could sorta push it sideways with my fingernail.
__________________
cmac

1986 300SDL, 315K
1987 BMW 325i, 440K
Reply With Quote
  #11  
Old 09-11-2009, 06:50 PM
Medmech's Avatar
Gone Waterboarding
 
Join Date: Feb 2007
Posts: 117
^^ a new phone may help but staying away from the sticky kind bud may also help.
Reply With Quote
  #12  
Old 09-11-2009, 07:48 PM
1lowdiesel's Avatar
Registered User
 
Join Date: Jul 2009
Posts: 75
i HATE T-Mobile. i never have service, their prices are insane and i never have service. yes i know i mentioned it twice but it's really annoying when my girl has 4 bars and i have zero till i get off her property.
__________________
83 300SD 226k virgin.

05 chevy duramax :bowdown:
air suspension + 500hp = fun for everyone

01 silverado 2wd 1500 5.9 cummins
Reply With Quote
  #13  
Old 09-12-2009, 02:04 AM
cmac2012's Avatar
Renaissance Dude
 
Join Date: Dec 2004
Location: Berkeley, CA
Posts: 15,419
Are you in a major urban area? Here in the Bay I do pretty well as far as signal strength, but there are a few spots that are weak that Verizon used to be strong in. My first phone contract was with GTE on an old Moto Star TAK.

They were weak in some spots but as soon as they merged with Bell Atlantic and later became Verizon, the service got way good. I guess it's too much too hope for that T-mobile will improve along a similar timeline.

Maybe I lucked out but the price I got is way good. $65 a month for 1000 minutes, unlimited text and unlimited web. I'm using it right now as a modem. It's about as good as the Verizon or AT&T 3G cards, and those are $60 a month just by themselves with a limit in bytes.
__________________
cmac

1986 300SDL, 315K
1987 BMW 325i, 440K

Last edited by cmac2012; 09-12-2009 at 02:39 AM.
Reply With Quote
  #14  
Old 09-12-2009, 02:08 AM
cmac2012's Avatar
Renaissance Dude
 
Join Date: Dec 2004
Location: Berkeley, CA
Posts: 15,419
Quote:
Originally Posted by iwrock View Post
How many days have you had the phone?

Does it only happen in a certain area, or in multiple areas?

My thought is that the problem lies in the phone. I would take it back to radioshack or sprint and see if they will replace it.
I've had it 20 days now. I had a 14 day money back deal. The problem seems to happen the most with two particular clients, both on land lines. Doesn't make sense, may just be a coincidence.

If I can't fix it with the troubleshooting page, I'm going to make myself unpopular at Radio Shack. Actually, they may be able to do the troubleshooting for me if I can't pull it off.
__________________
cmac

1986 300SDL, 315K
1987 BMW 325i, 440K
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page