Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > General Discussions > Off-Topic Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-21-2013, 04:35 PM
Registered User
 
Join Date: May 2011
Location: NYC
Posts: 5,505
RANT: Apple MagSafe adapters...

have the life span of a 50-yo man with an inoperable abdominal tumor. If Apple can't get their strain relief design right after 6 years, then at least make the portion that connects to the computer detachable, and sell the thing for $20 or so, rather than charging $80+tax for the whole 9 yards.

Interestingly, when I cut the cord apart, it looked like part of the inner wiring had melted. Plus it looked like the sheath wire (negative return, probably) had oxidized -- it was blackish rather than silver in color. This is still a better mode of failure than my last deadski adapter, which failed by melting the end off and actually smoldering.

Reply With Quote
  #2  
Old 02-21-2013, 04:39 PM
Jorn's Avatar
Registered User
 
Join Date: Nov 2003
Location: TheFlyingDutchManInHollywood
Posts: 5,662
Quote:
Originally Posted by spdrun View Post
have the life span of a 50-yo man with an inoperable abdominal tumor. If Apple can't get their strain relief design right after 6 years, then at least make the portion that connects to the computer detachable, and sell the thing for $20 or so, rather than charging $80+tax for the whole 9 yards.

Interestingly, when I cut the cord apart, it looked like part of the inner wiring had melted. Plus it looked like the sheath wire (negative return, probably) had oxidized -- it was blackish rather than silver in color. This is still a better mode of failure than my last deadski adapter, which failed by melting the end off and actually smoldering.
Had the same thing. And as a bonus the battery of my 17inch starts to expand again, second time this happens.
__________________
Black on Black 1979 300CD (sold), 1990 Black 300SE, Silver 1989 Volvo 780, 1988 300CE
Reply With Quote
  #3  
Old 02-21-2013, 04:43 PM
iwrock's Avatar
roflmonster
 
Join Date: Nov 2003
Location: Hella NorCal
Posts: 3,313
I just wish that it popped out a little easier.


Killed the casing twice on mine, as it didn't pop out as advertised when people tripped over the wire!
__________________
-Justin

91 560 SEC AMG - other dogs dd
01 Honda S2000 - dogs dd
07 MB ML320 CDI - dd
16 Lexus IS250 - wifes dd

it's automatic.
Reply With Quote
  #4  
Old 02-21-2013, 05:35 PM
LandYaghtLover's Avatar
Registered User
 
Join Date: Jun 2010
Location: Green Bay, WI
Posts: 1,341
The design where the cord runs parallel to the body is the worst for trip hazards as it locks in tighter.

Anyway. I just bought a new 85 watt a few days ago for my 2006 MacBook Pro 17". It had been running on a old MacBook 45 watt adapter for some time now. The end at the book failed internally to some extent. But the other end fell apart. After dealing with it a lot and plans on selling, I bought a new one.

Get this. The new one, while compatible according to Apple, does not work right. For the SMC to recognize the adapter and begin use I have to either shutdown or set the machine to sleep. If its awake and running, no light on the adapter and no charging. While its nice to have the right adapter output wise, this can be a little bit of a pain.
__________________
1991 560 SEL / 185k miles
1992 750il / 17k miles - project car
Reply With Quote
  #5  
Old 02-21-2013, 05:43 PM
Registered User
 
Join Date: May 2011
Location: NYC
Posts: 5,505
Return the f**king thing if it's incompatible.
Reply With Quote
  #6  
Old 02-21-2013, 05:56 PM
LandYaghtLover's Avatar
Registered User
 
Join Date: Jun 2010
Location: Green Bay, WI
Posts: 1,341
Quote:
Originally Posted by spdrun View Post
Return the f**king thing if it's incompatible.
So then I would have no power adapter. Thats great logic.
__________________
1991 560 SEL / 185k miles
1992 750il / 17k miles - project car
Reply With Quote
  #7  
Old 02-21-2013, 06:12 PM
Registered User
 
Join Date: May 2011
Location: NYC
Posts: 5,505
Quote:
Originally Posted by LandYaghtLover View Post
So then I would have no power adapter. Thats great logic.
Tell the CrApple "Genius" to suggest a solution to the problem or come up with an adapter that works. BTW - did you try resetting the firmware?
Reply With Quote
  #8  
Old 02-21-2013, 07:25 PM
LandYaghtLover's Avatar
Registered User
 
Join Date: Jun 2010
Location: Green Bay, WI
Posts: 1,341
Quote:
Originally Posted by spdrun View Post
Tell the CrApple "Genius" to suggest a solution to the problem or come up with an adapter that works. BTW - did you try resetting the firmware?
How does one reset the firmware? I did an SMC reset and a VRAM reset for the fun of it as well as making sure I had the latest firmware. But I have no clue how to reset it. Google gave me nothing on that too. I guess its worth a shot, but others have the same issues with these adapter on older hardware.
__________________
1991 560 SEL / 185k miles
1992 750il / 17k miles - project car
Reply With Quote
  #9  
Old 02-21-2013, 07:36 PM
Registered User
 
Join Date: May 2011
Location: NYC
Posts: 5,505
Quote:
Originally Posted by LandYaghtLover View Post
How does one reset the firmware? I did an SMC reset and a VRAM reset for the fun of it as well as making sure I had the latest firmware. But I have no clue how to reset it. Google gave me nothing on that too. I guess its worth a shot, but others have the same issues with these adapter on older hardware.
Try an NVRAM reset as well: Command-Opt-P-R held down together immediately after powering up.
Reply With Quote
  #10  
Old 02-21-2013, 07:36 PM
Can't Know's Avatar
Registered Slacker
 
Join Date: Sep 2010
Location: Sunny CA
Posts: 733
You guys are deluding yourselves.

Everyone knows that Apple stuff never breaks or wears out and that the stuff they sell you at the Apple store works perfectly every time!
Reply With Quote
  #11  
Old 02-22-2013, 08:57 AM
elchivito's Avatar
ĦAy Jodido!
 
Join Date: Aug 2009
Location: Rancho Disparates
Posts: 4,075
You didn't buy AppleCare?
Silly you.
__________________
You're a daisy if you do.
__________________________________
84 Euro 240D 4spd. 220.5k sold
04 Honda Element AWD
1985 F150 XLT 4x4, 351W with 270k miles, hay hauler
1997 Suzuki Sidekick 4x4
1993 Toyota 4wd Pickup 226K and counting
Reply With Quote
  #12  
Old 02-22-2013, 09:02 AM
elchivito's Avatar
ĦAy Jodido!
 
Join Date: Aug 2009
Location: Rancho Disparates
Posts: 4,075
Quote:
Originally Posted by spdrun View Post
Try an NVRAM reset as well: Command-Opt-P-R held down together immediately after powering up.
hold down till after you've heard three startup chimes
__________________
You're a daisy if you do.
__________________________________
84 Euro 240D 4spd. 220.5k sold
04 Honda Element AWD
1985 F150 XLT 4x4, 351W with 270k miles, hay hauler
1997 Suzuki Sidekick 4x4
1993 Toyota 4wd Pickup 226K and counting
Reply With Quote
  #13  
Old 02-22-2013, 09:13 AM
Registered User
 
Join Date: May 2011
Location: NYC
Posts: 5,505
Quote:
Originally Posted by elchivito View Post
You didn't buy AppleCare?
Silly you.
Actually, I got the previous adapter replaced for free by going into the 57th St Apple store, waving the burnt off cord around, and speaking loudly that it almost set my tablecloth on fire. (with other customers staring with great interest). Basically, they stuck a new adapter in my hand and ushered me out the door. Yes, I tried asking nicely first.

With this one, I found my sister's broken adapter with good MagSafe and frankensteined the two together. F--- paying Crapple a few hundred bucks to replace what would have cost them 5 cents extra to build properly in the first place.
Reply With Quote
  #14  
Old 02-22-2013, 09:29 AM
MTI's Avatar
MTI MTI is offline
Registered User
 
Join Date: Nov 2002
Location: Scottsdale, Arizona
Posts: 10,626
Quote:
Originally Posted by Can't Know View Post
You guys are deluding yourselves.

Everyone knows that Apple stuff never breaks or wears out and that the stuff they sell you at the Apple store works perfectly every time!
Just like Mercedes.
Reply With Quote
  #15  
Old 02-22-2013, 09:44 AM
E150GT's Avatar
I'm a chicken
 
Join Date: Sep 2006
Location: SAN ANTONIO, TEXAS
Posts: 1,148
Hmm. I am a usual apple basher but I have had nary a problem with my MBP. Now my iphone, I cant wait to drop that POS!

__________________
1984 300SD Orient Red/ Palomino
1989 560SEC
2016 Mazda 6 6 speed manual
1995 Ford F-150 reg cab 4.9 5speed manual
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page