Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > General Discussions > Off-Topic Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-16-2003, 11:53 AM
3 MB's and counting!
 
Join Date: Apr 2001
Location: Toronto, Canada
Posts: 1,825
Belt noises in cold climate....

My 126 for years now, when its cold outside and you first start it up after a few hours the belts make this noise thats not belt squeling but sounds like a "crying" or "whistling" noise and gets louder at certain rpms then fades away then comes back. It does this until the engine completely warms up then stops.

Anyone expeirence this? The car did this for years and just blamed it on the cold.

__________________
99 C43
98 S420
99 C230K
01 C240
Reply With Quote
  #2  
Old 02-16-2003, 03:23 PM
Registered User
 
Join Date: Jul 2000
Location: Toronto, CANADA
Posts: 1,193
Most likely the secondary air pump. This is located under the alternator on the V8 cars and only runs on start up until the engine is warm. Sounds like the bearings inside are going. I had the same thing on my 420SEL and had to replace it. It is not a cheap part. Some people just disconnect it, apparently it unplugs. As far as I know it only affects the emmissions system and having it off will not wreck anything else, but if you need to pass emmissions tests you will most likely need it in working order. However, I don't think we need to test cars over 20 years in Ontario unless you're up for emmissions testing this year you may not have to do it in the future.
__________________
Jason Priest
1999 E430
1995 E420 - retired
1986 420SEL - retired
Reply With Quote
  #3  
Old 02-16-2003, 04:01 PM
3 MB's and counting!
 
Join Date: Apr 2001
Location: Toronto, Canada
Posts: 1,825
420 i know what you are talking about, its the pollution pump and yes in the summer that was disconnected due to a fluttering noise it started to make. This noise is from the belts.
__________________
99 C43
98 S420
99 C230K
01 C240
Reply With Quote
  #4  
Old 02-16-2003, 05:17 PM
3 MB's and counting!
 
Join Date: Apr 2001
Location: Toronto, Canada
Posts: 1,825
should I have them replaced? I doubt that they are in the condition that it will snap or something.

__________________
99 C43
98 S420
99 C230K
01 C240
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page