Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > General Discussions > Off-Topic Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-28-2004, 03:47 PM
Registered User
 
Join Date: Jan 2000
Location: ny, ny
Posts: 112
a/c not working

I have a 190 e 2.3 1987.

The a/c works only when the defrost button is depressed, what do you think is hould do so that the a/c button wil work.I was thinking about replacing the climate controll panel.
Your thoughts?
Reply With Quote
  #2  
Old 05-28-2004, 10:38 PM
sixto's Avatar
smoke gets in your eyes
 
Join Date: Jun 2000
Location: SF Bay Area
Posts: 20,793
Does it work in other modes if you leave the fan control setting on max? Might be a problem with the blower regulator rather than something inside the PBU.

Sixto
95 S420
87 300SDL
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page