Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Search Forums

Showing results 1 to 30 of 95
Search took 0.02 seconds.
Search: Posts Made By: dhillman
Forum: Tech Help 04-19-2018, 05:42 PM
Replies: 3
Views: 730
Posted By dhillman
Thanks!

Thanks!
Forum: Tech Help 04-15-2018, 12:40 PM
Replies: 3
Views: 730
Posted By dhillman
Hello. In my last 2 threads, Iíve not receive any...

Hello. In my last 2 threads, Iíve not receive any answer. Not sure if it was technically complicated or my puertorrican english.

Anyway I found out that the ESL and the key were working. I sent it...
Forum: Tech Help 03-15-2018, 08:24 AM
Replies: 3
Views: 730
Posted By dhillman
Key wonít turn.

Hi friends. I did a quick look to find an answer to my problem, but couldnít find a thread that covers my issue. This is an S430 2001. The key wonít turn. It happened before. Fixed by getting a new...
Forum: Tech Help 02-10-2015, 07:28 AM
Replies: 0
Views: 416
Posted By dhillman
Airmatic problems

Hi, friends. Last week I had a deflated front Arnott strut passenger side on my 2001, S430 car. I order an Arnott replacement and installed it this weekend. During my test drive I noticed that the...
Forum: Tech Help 08-29-2014, 09:52 AM
Replies: 19
Views: 1,165
Posted By dhillman
Success story so far. Replaced the CPS and the...

Success story so far. Replaced the CPS and the car is back to bussiness. Thank you for your interest.

Darrel
Forum: Tech Help 08-28-2014, 01:31 PM
Replies: 19
Views: 1,165
Posted By dhillman
Thank you very much all of you. This is...

Thank you very much all of you. This is embarrassing, I apologize , but when I went last night to remove and re-inspect the ECU, I noticed that one of the plugs with the lever was not in all the way....
Forum: Tech Help 08-27-2014, 02:39 PM
Replies: 19
Views: 1,165
Posted By dhillman
Thank You Vince, mine is located in the engine...

Thank You Vince, mine is located in the engine room compartment at the passenger side, side by side with the N3/10 (ECU).
I posted in another forum, and Eric told me that the fan at high speed with...
Forum: Tech Help 08-27-2014, 11:47 AM
Replies: 19
Views: 1,165
Posted By dhillman
Thank you Zulficar. Can you tell me where I can...

Thank you Zulficar. Can you tell me where I can get information of how and why the Fan is on when the ECU is off-line? I'll get the wiring diagram of the K40 and identify the STARTER relay to see if...
Forum: Tech Help 08-27-2014, 10:15 AM
Replies: 19
Views: 1,165
Posted By dhillman
Thank you Vince. By the look of K40, It looks...

Thank you Vince. By the look of K40, It looks expensive. Is that part also programmed to the VIN number? I saw there is a CHIP inside the K40.

Thank you again for letting me know that indeed...
Forum: Tech Help 08-27-2014, 05:25 AM
Replies: 8
Views: 546
Posted By dhillman
This is the message I get on the screen. Now that...

This is the message I get on the screen. Now that the fan is running voltage gets low. See the attachment. ECU PART NUMBER IS A0305455932, Bosch 261 206 971. Darrel
Forum: Tech Help 08-27-2014, 04:41 AM
Replies: 8
Views: 546
Posted By dhillman
I just charge the battery, it went up from 9.95V...

I just charge the battery, it went up from 9.95V to 12.48V as per the Fluke meter and 13.1V as per DAS. Again same message, "communication error with the control unit". It seems like N3/10 is fried....
Forum: Tech Help 08-27-2014, 04:40 AM
Replies: 19
Views: 1,165
Posted By dhillman
I just charge the battery, it went up from 9.95V...

I just charge the battery, it went up from 9.95V to 12.48V as per the Fluke meter and 13.1V as per DAS. Again same message, "communication error with the control unit". It seems like N3/10 is fried....
Forum: Tech Help 08-26-2014, 09:59 PM
Replies: 8
Views: 546
Posted By dhillman
I tried to get the codes, there are many faults...

I tried to get the codes, there are many faults but there is no communication with the ECU. The message says: communication Error: communication with control module interrupted, possible causes......
Forum: Tech Help 08-26-2014, 02:12 PM
Replies: 8
Views: 546
Posted By dhillman
Thank you. I will start with the K40. Also...

Thank you. I will start with the K40. Also check on the anti-theft.

Darrel
Forum: Tech Help 08-26-2014, 02:08 PM
Replies: 19
Views: 1,165
Posted By dhillman
Thank you again. I did check de N3/10 for pin...

Thank you again. I did check de N3/10 for pin damage, but I couldn't see any. I will remove the K40 which I found it in the service manual, and inspect everywhere for blown fuse and also have seen...
Forum: Tech Help 08-26-2014, 10:25 AM
Replies: 8
Views: 546
Posted By dhillman
S430 No crancking, No starting

Hi friends, after removal of the N3/10 ignition control unit from the right engine compartment fuse box, the car no longer start, not even cranck. The battery is charged, the remote control is...
Forum: Tech Help 08-25-2014, 01:37 PM
Replies: 19
Views: 1,165
Posted By dhillman
Thank you

Thank you. Can you give me more information even for the old models? Maybe I can trace the relay in my car. Well that still be the case even though everyting inside the car is working, like close...
Forum: Tech Help 08-25-2014, 09:18 AM
Replies: 19
Views: 1,165
Posted By dhillman
CAN removal with bad consequence

Hello friends, last post was in 2009. I guess my S430 is getting old, so I am in need of assistance to diagnose the new problems I am facing. This is a 2001, 220170 S430 Mercedes Benz. Everything...
Forum: Tech Help 05-11-2010, 11:28 AM
Replies: 4
Views: 2,374
Posted By dhillman
Dumb quedtion

Question to any member. Would you say this section is for information only so you get the job done by a professional mechanic or for a do it yourselver as me? Thank you. Darrel.
Forum: Tech Help 05-10-2010, 12:04 PM
Replies: 1
Views: 2,577
Posted By dhillman
Repair of Airmatic Strut

In a previous thread about the squeaking sound at the front suspension, I found out as most of you replied that the lower ball joints were worm out and rusted. When replacing the ball joints I...
Forum: Tech Help 05-10-2010, 10:58 AM
Replies: 4
Views: 2,374
Posted By dhillman
Update in transmission oil leak

After placing some absorbent pads in the lower transmission cover I found the red oil saturating the pad, with some drops of oil coming from the electric switch connector on the passenger side. ...
Forum: Tech Help 04-20-2010, 09:19 AM
Replies: 4
Views: 2,374
Posted By dhillman
Transmission leak

Thank you MB Doc, That was what I was aiming to. I remove the metal cover protecting the connector and saw some of the fluid at the bottom of the casting. Also the electrical wires and connectors...
Forum: Tech Help 04-19-2010, 11:05 PM
Replies: 4
Views: 2,374
Posted By dhillman
W220 Transmission oil leak

Hi friends. S430/2001, found some clear oil in the floor, yellowish to pink color. Jack-up the front of the car, removed the 2 engine cover panels. The panel at the automatic transmission had oil...
Forum: Tech Help 03-31-2010, 02:59 PM
Replies: 5
Views: 1,441
Posted By dhillman
Up-date in this issue.

I have a universal tool for removing most lower ball joint. Will this tool work for this ball joint? Any friend that had replace this ball joint in this car before. what tool did you use?
I have...
Forum: Tech Help 03-31-2010, 02:51 PM
Replies: 5
Views: 2,837
Posted By dhillman
Follow up on this issue

Hi friends. I managed to get another pump from an older model. I just remove the electric motor and vacuum pump assembly and attached it to the old one. It worked for 6 weeks but eventually the...
Forum: Tech Help 02-14-2010, 06:12 AM
Replies: 5
Views: 1,441
Posted By dhillman
Thank you all

Thank you, I did this in my W126, with the special press. I read that this lower ball joint can be replace with a special tool without removing any part of the suspension. Is this an easy job? Can I...
Forum: Tech Help 02-12-2010, 12:56 PM
Replies: 5
Views: 1,441
Posted By dhillman
Squeaky sound at front suspension

Hi friends. I have a squeaky sound at my front suspension in my S430 2001 W220 chassis Mercedes. I inspected the area, the sound comes from the disk brake inner plate. It sounds in both, when...
Forum: Tech Help 12-24-2009, 06:59 AM
Replies: 5
Views: 2,837
Posted By dhillman
Thank you for your comments

I got the used pump, and although is very different, it is a Hella instead of a Bosch, the 12 V. motor is identical, the bipressure pump is different but it seems to fit in the PSE housing. Today...
Forum: Tech Help 12-18-2009, 06:26 AM
Replies: 5
Views: 2,837
Posted By dhillman
PSE problem, central locking system.

Hi,guys. Long time since my last thread, but now my car is getting old and I need some advice. I have an S430, 2001-220170. The PSE pump just melted the other day then blew the fuse. I removed the...
Forum: Tech Help 02-25-2009, 10:07 AM
Replies: 2
Views: 482
Posted By dhillman
My mistake, looking at the Owner's Manual I was...

My mistake, looking at the Owner's Manual I was looking for the wrong bulb (High Beam). Removed the Low Beam, more lateral and put a new one, problem solved. The only thing is that the metal clip...
Showing results 1 to 30 of 95

 
Forum Jump


All times are GMT -4. The time now is 09:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page