Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Search Forums

Showing results 1 to 11 of 11
Search took 0.02 seconds.
Search: Posts Made By: billwach
Forum: Mercedes Used Parts For Sale & Wanted 04-20-2002, 12:46 PM
Replies: 2
Views: 556
Posted By billwach
Parting out my 190E l984...if you Email...

Parting out my 190E l984...if you Email me...billwach@hotmail.com
will give you a call or give you my no.

Thanks

Bill
Forum: Tech Help 04-08-2002, 07:48 PM
Replies: 11
Views: 1,625
Posted By billwach
Just cam across 190E motor mounts in Preformance...

Just cam across 190E motor mounts in Preformance Paddack...this seems to be what I will do and then let you know.
Did not find this thread using "Search" ...couldn't, alway showed no matches.
Forum: Tech Help 04-08-2002, 07:16 PM
Replies: 11
Views: 1,625
Posted By billwach
Thanks for getting in on the discussion. My car...

Thanks for getting in on the discussion. My car shakes at idle in drive only...it is smooth in park reverse and neutral. Also my car
does not heat up...tack welded the broken clutch fan so is...
Forum: Tech Help 04-08-2002, 05:15 PM
Replies: 11
Views: 1,625
Posted By billwach
will check the motor mounts tomorrow 4/9/02 and...

will check the motor mounts tomorrow 4/9/02 and let everybody know what I find. Why does it not vibrate in reverse? ... like it does in the forward gears.
Forum: Tech Help 04-05-2002, 06:25 PM
Replies: 11
Views: 1,625
Posted By billwach
How do I check motor mounts...other than looking...

How do I check motor mounts...other than looking for cracks and checks. Car has 100M+ do you change them as maintance.
Forum: Tech Help 04-04-2002, 10:57 AM
Replies: 11
Views: 1,625
Posted By billwach
Motor mounts seems OK...the engine idles smooth...

Motor mounts seems OK...the engine idles smooth in Park, Neutral, and Reverse...like glass 750RPM, but when shifted to drive the whole car shakes...almost acts like the converter not disengaging, but...
Forum: Tech Help 04-03-2002, 05:11 PM
Replies: 11
Views: 1,625
Posted By billwach
Question rough idle in drive 190E

Car idles right in park and neutral and reverse...smooth, but when shifted to drive, 3rd, or 2nd it idles rough. Have read all the threads on this but nothing seems to help. Have done the
idle...
Forum: Tech Help 03-16-2002, 04:49 PM
Replies: 2
Views: 620
Posted By billwach
Thanks everyone for the help...found 10AMP fuse...

Thanks everyone for the help...found 10AMP fuse blown behind the battery...everything, cold start valve, idle control valve, transmission engagement, all are working now. thanks
Forum: Tech Help 03-15-2002, 10:39 AM
Replies: 2
Views: 620
Posted By billwach
tranmission engage at idle

l987 190E. Thanks to all who have responded to threads...have
the 190E idleing properly, but when engaging auto tran into drive or reverse the idle drops 600-700 rpm and will die. It seems the...
Forum: Tech Help 03-12-2002, 07:06 PM
Replies: 0
Views: 472
Posted By billwach
Idle control valve 190E

removed the two wire clip from my ICV and no change in RPM.
Car will not idle with arm against stop...have to adjust cable, also
the seems like the auto tran drags at stop sign...help new owner
Forum: Tech Help 03-11-2002, 04:29 PM
Replies: 1
Views: 768
Posted By billwach
190E 1987 tune up info

Help just bot car ...how you check cold start valve and any help on ;tune up, also seems to creep at stop sign...anyother thing to look for in getting to run right is wanted.
Showing results 1 to 11 of 11

 
Forum Jump


All times are GMT -4. The time now is 05:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page