Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Search Forums

Showing results 1 to 30 of 190
Search took 0.04 seconds.
Search: Posts Made By: BENZ TEK
Forum: Tech Help 10-18-2013, 12:09 PM
Replies: 1
Views: 762
Posted By BENZ TEK
2007 Mercedes C230 Overhead control module

Hello all. Does anyone know if the overhead control modules have to be programmed/ coded before installation in my C230?
Forum: Tech Help 10-18-2013, 12:07 PM
Replies: 37
Views: 9,250
Posted By BENZ TEK
Thanks MBDOC for being a true Mentor/Friend all...

Thanks MBDOC for being a true Mentor/Friend all these years. Don't forget that I'm still interested in what we talked about all those years ago. Lol Have fun and enjoy yourself. Also thank you for...
Forum: Tech Help 04-04-2013, 10:47 AM
Replies: 7
Views: 5,573
Posted By BENZ TEK
Yes. The little pigtail wiring harnesses are also...

Yes. The little pigtail wiring harnesses are also a know fault that plugs into the magnets. The dealer has an open campaign going right now. They should replace them free of charge.
Forum: Tech Help 03-20-2013, 10:14 AM
Replies: 2
Views: 728
Posted By BENZ TEK
Thanks for the info. I will do some more research.

Thanks for the info. I will do some more research.
Forum: Tech Help 03-18-2013, 08:51 PM
Replies: 2
Views: 728
Posted By BENZ TEK
1998 ML320 tranny swap to 1998 E320

Just checking to see if it could be done since I have a 1998 ML 320 transmission with computer. The transmission is starting to go in my 1998 E320. Looks like I can take the back tail housing loose...
Forum: Tech Help 01-31-2013, 02:48 PM
Replies: 9
Views: 3,794
Posted By BENZ TEK
Thanks Tim. Let me try that first.

Thanks Tim. Let me try that first.
Forum: Tech Help 01-31-2013, 09:06 AM
Replies: 9
Views: 3,794
Posted By BENZ TEK
I checked the bushings and they are fine. No play...

I checked the bushings and they are fine. No play or slop in the linkage. I am going to take a shot an change the conductor plate. Hopefully that will fix it. I will let y'all know of the outcome....
Forum: Tech Help 01-30-2013, 09:27 PM
Replies: 9
Views: 3,794
Posted By BENZ TEK
I think the issue is electrical. When you watch...

I think the issue is electrical. When you watch the live data feed shifting from park to reverse it syncs up correctly. When the car get hot both indicators show park but when you move the gear...
Forum: Tech Help 01-30-2013, 11:13 AM
Replies: 9
Views: 3,794
Posted By BENZ TEK
1998 E320 won't engage into gear when car warms up.

Hello all. I have a 1998 E320 that will not engage into reverse or drive once the engine starts building some temperature. I checked for codes in the transmission computer but the last shop erased...
Forum: Tech Help 01-26-2013, 08:44 AM
Replies: 7
Views: 5,573
Posted By BENZ TEK
Yes. All of the early cars with a 272 engine have...

Yes. All of the early cars with a 272 engine have that problem.
Forum: Tech Help 01-24-2013, 11:29 AM
Replies: 6
Views: 1,021
Posted By BENZ TEK
Thanks Gilly. I'm going to make a pigtail from...

Thanks Gilly. I'm going to make a pigtail from the crank position sensor and hook it to a scope. I will let you know of my findings!!
Forum: Tech Help 01-23-2013, 01:54 PM
Replies: 6
Views: 1,021
Posted By BENZ TEK
Ok I think I have it narrowed down to the base...

Ok I think I have it narrowed down to the base module but not sure. I don't have injector pulse but I do have fuel pressure. Any ideas?
Forum: Tech Help 01-18-2013, 07:36 AM
Replies: 6
Views: 1,021
Posted By BENZ TEK
Transmission has been removed

I think it has because the dipstick is not attached to the side of the head like its suppose to be. I was going to put a bolt in it but haven't gotten around to that yet. What are you thinking?
Forum: Tech Help 01-17-2013, 01:48 PM
Replies: 6
Views: 1,021
Posted By BENZ TEK
1996 E320

Hello All. I have a 96 E320 that has a starting issue. This is what I found so far. There were codes in the computer relating to not having a signal from the crankshaft position sensor as well as a...
Forum: Tech Help 12-18-2012, 10:40 AM
Replies: 2
Views: 676
Posted By BENZ TEK
Thanks Pat

Yes I changed the relay but it was used. Caused the same issue. Lol I got a new one and the car works fine now. Thanks for the help!!
Forum: Tech Help 12-17-2012, 02:08 PM
Replies: 2
Views: 676
Posted By BENZ TEK
2001 ML320

I have a 2001 ML 320 that has a problem with keeping the ABS pump energized. It is giving me a code stating that the ABS pump will not shut off. I think theres a relay issue keeping the pump...
Forum: Mercedes-Benz Used Parts For Sale & Wanted 08-27-2012, 01:36 PM
Replies: 0
Views: 495
Posted By BENZ TEK
2.3-16V shell/1995 C280 for parts for sell

I have a shell for sale. Its stripped down in order to make a race car out of it but that project is scrapped. I have an engine out of a 1995 E320 that has a broken oil pan. It may still be good but...
Forum: Tech Help 07-31-2012, 10:27 AM
Replies: 1
Views: 2,123
Posted By BENZ TEK
1997 SL500 Convertible Top Operation

Hello everyone! I have a 1997 SL500 that has a roll bar thats stuck and will not move. Also since thats not operating the top will not operate. I believe one of the switches may have an issue but I...
Forum: Tech Help 07-21-2012, 12:01 PM
Replies: 2
Views: 2,226
Posted By BENZ TEK
I will try to use the SDS Monday and activate the...

I will try to use the SDS Monday and activate the camshafts so I can watch their movement. Thank you for the info on the transmission. I thought the newer transmissions would be different but I guess...
Forum: Tech Help 07-19-2012, 07:18 PM
Replies: 2
Views: 2,226
Posted By BENZ TEK
2007 C230 P2767&P0025

Hi all!! I have a C230 in the shop for two codes. One is a P2767 input turbine speed sensor B circuit no signal pending. P0025 exhaust camshaft position timing over retarded bank 2. This is a code...
Forum: Tech Help 04-24-2012, 10:38 PM
Replies: 1
Views: 789
Posted By BENZ TEK
1998 E430 Charging issue

Hello all!! I have a E430 thats not charging properly. I believe the cause to be not enough voltage on the small wire leading to the alternator. If you rev the car up it charges fine but as soon as...
Forum: Tech Help 03-02-2012, 09:32 AM
Replies: 11
Views: 1,752
Posted By BENZ TEK
The flange bushings are located in the lower hub...

The flange bushings are located in the lower hub and is attached at the end of the control arm. Basically at the bottom of the hub carrier.
Forum: Tech Help 03-01-2012, 12:08 AM
Replies: 18
Views: 9,522
Posted By BENZ TEK
I always use a heavy duty slide hammer to remove...

I always use a heavy duty slide hammer to remove the flange. The bearing comes out with a removal tool but it's to expensive for a one time deal.
Forum: Tech Help 03-01-2012, 12:01 AM
Replies: 11
Views: 1,752
Posted By BENZ TEK
Also check the rear lower flange joint bushing as...

Also check the rear lower flange joint bushing as well. I have had several issues related to noise like a creeping sound and they were the culprits. Also if the car is on the ground you can put the...
Forum: Tech Help 02-29-2012, 11:48 PM
Replies: 1
Views: 965
Posted By BENZ TEK
Any ideas?

Any ideas?
Forum: Tech Help 02-29-2012, 11:46 PM
Replies: 5
Views: 991
Posted By BENZ TEK
May be due to a faulty airflow meter. If the pot...

May be due to a faulty airflow meter. If the pot on the side of the airflow meter is sending a incorrect reading then the idle valve is going to try and compensate for the new value its reading. Use...
Forum: Tech Help 02-29-2012, 11:40 PM
Replies: 2
Views: 647
Posted By BENZ TEK
Use a lubricant that won't attack rubber. Also...

Use a lubricant that won't attack rubber. Also make sure it's a rust inhibitor as well. Wrap it up tightly in plastic then put it in a ziplock bag. If you maintain the fuel system on a regular basis...
Forum: Tech Help 02-29-2012, 11:33 PM
Replies: 7
Views: 1,982
Posted By BENZ TEK
They are correct. F8dc4 is the own plug.

They are correct. F8dc4 is the own plug.
Forum: Tech Help 02-29-2012, 10:18 AM
Replies: 1
Views: 965
Posted By BENZ TEK
2000 S500 suspension leak

Hi all. I have a S500 that leaks down over night and sits low to the ground. So far I know the front shocks have been replaced. I can tell by looking at the height of the car that the right rear...
Forum: Tech Help 02-15-2012, 09:29 AM
Replies: 1
Views: 843
Posted By BENZ TEK
1991 300sl roolbar light, traction control light and abs light on

I have a 91 300sl that has all three lights on at the same time. Does anyone know of a way to go into the traction computer and retrieve codes? Thanks in advance!!
Showing results 1 to 30 of 190

 
Forum Jump


All times are GMT -4. The time now is 07:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page